CVE-2026-41705 Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs
Attackers can execute arbitrary code via filter-expression injection in Spring AI's MilvusVectorStore using unsanitized document IDs.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41705?
CVE-2026-41705 is a high-severity code injection vulnerability in Spring AI, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs. Spring AI 1.0.x: affected from 1.0.0 through latest 1.0.x; upgrade to 1.0.7 or greater. Spring AI 1.1.x: affected from 1.1.0 through latest 1.1.x; upgrade to 1.1.6 or greater.
Weakness: CWE-917
Which versions are affected by CVE-2026-41705?
8 open source packages ship an affected version, including org.springframework.ai:spring-ai-milvus-store and org.springframework.ai:spring-ai-typesense-store. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.ai:spring-ai-milvus-store Maven | From 1.0.0 | 1.0.7 |
org.springframework.ai:spring-ai-milvus-store Maven | From 1.0.0 | 1.0.7 |
org.springframework.ai:spring-ai-milvus-store Maven | From 1.1.0 | 1.1.6 |
org.springframework.ai:spring-ai-milvus-store Maven | From 1.1.0 | 1.1.6 |
org.springframework.ai:spring-ai-typesense-store Maven | From 1.0.0 | 1.0.7 |
org.springframework.ai:spring-ai-typesense-store Maven | From 1.0.0 | 1.0.7 |
2 more packages
org.springframework.ai:spring-ai-typesense-store Maven | From 1.1.0 | 1.1.6 |
org.springframework.ai:spring-ai-typesense-store Maven | From 1.1.0 | 1.1.6 |
Products include Vmware Spring Ai.
How do I fix CVE-2026-41705?
Upgrade org.springframework.ai:spring-ai-milvus-store to a fixed version for your release line: 1.0.7 or 1.1.6.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-41705 being exploited?
There is no known exploitation of CVE-2026-41705 in the wild and no public exploit code.
Other vulnerabilities in Spring AI
- CVE-2026-22738 SpEL Injection via Unescaped Filter Key in SimpleVectorStore Leads to Remote Code Execution
- CVE-2026-40978 Spring AI has SQL Injection in CosmosDBVectorStore.doDelete()
- CVE-2026-22730 CVE-2026-22730: SQL Injection in Spring AI MariaDBFilterExpressionConverter
- CVE-2026-47835 Spring AI vector store metadata filtering to handle special characters in Elasticsearch, OpenSearch, and GemFire Vector Stores
- CVE-2026-40967 Spring AI has a VectorStore FilterExpression Converter injection
Sources
Also known as GHSA-v632-2m87-7469.