# CVE-2026-41705: Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs

> Attackers can execute arbitrary code via filter-expression injection in Spring AI's MilvusVectorStore using unsanitized document IDs.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-v632-2m87-7469

## What is CVE-2026-41705?

CVE-2026-41705 is a high-severity code injection vulnerability in Spring AI, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs.
Spring AI 1.0.x: affected from 1.0.0 through latest 1.0.x; upgrade to 1.0.7 or greater. Spring AI 1.1.x: affected from 1.1.0 through latest 1.1.x; upgrade to 1.1.6 or greater.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2026-41705?

8 open source packages ship an affected version, including org.springframework.ai:spring-ai-milvus-store and org.springframework.ai:spring-ai-typesense-store. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.ai:spring-ai-milvus-store` | Maven | From 1.0.0 | 1.0.7 |
| `org.springframework.ai:spring-ai-milvus-store` | Maven | From 1.0.0 | 1.0.7 |
| `org.springframework.ai:spring-ai-milvus-store` | Maven | From 1.1.0 | 1.1.6 |
| `org.springframework.ai:spring-ai-milvus-store` | Maven | From 1.1.0 | 1.1.6 |
| `org.springframework.ai:spring-ai-typesense-store` | Maven | From 1.0.0 | 1.0.7 |
| `org.springframework.ai:spring-ai-typesense-store` | Maven | From 1.0.0 | 1.0.7 |
| `org.springframework.ai:spring-ai-typesense-store` | Maven | From 1.1.0 | 1.1.6 |
| `org.springframework.ai:spring-ai-typesense-store` | Maven | From 1.1.0 | 1.1.6 |

Products: Vmware Spring Ai.

## How do I fix CVE-2026-41705?

Upgrade org.springframework.ai:spring-ai-milvus-store to a fixed version for your release line: 1.0.7 or 1.1.6.

## Is CVE-2026-41705 being exploited?

There is no known exploitation of CVE-2026-41705 in the wild and no public exploit code.

## Other vulnerabilities in Spring AI

- [CVE-2026-22738](https://insights.sbomify.com/CVE-2026-22738/): SpEL Injection via Unescaped Filter Key in SimpleVectorStore Leads to Remote Code Execution (critical 9.8)
- [CVE-2026-40978](https://insights.sbomify.com/CVE-2026-40978/): Spring AI has SQL Injection in CosmosDBVectorStore.doDelete() (high 8.8)
- [CVE-2026-22730](https://insights.sbomify.com/CVE-2026-22730/): CVE-2026-22730: SQL Injection in Spring AI MariaDBFilterExpressionConverter (high 8.8)
- [CVE-2026-47835](https://insights.sbomify.com/CVE-2026-47835/): Spring AI vector store metadata filtering to handle special characters in Elasticsearch, OpenSearch, and GemFire Vector Stores (high 8.6)
- [CVE-2026-40967](https://insights.sbomify.com/CVE-2026-40967/): Spring AI has a VectorStore FilterExpression Converter injection (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41705 and fix it if it is affected.

What it is: CVE-2026-41705 is a high-severity code injection vulnerability in Spring AI, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41705 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.ai:spring-ai-milvus-store (Maven): affected from 1.0.0; fixed in 1.0.7
- org.springframework.ai:spring-ai-milvus-store (Maven): affected from 1.0.0; fixed in 1.0.7
- org.springframework.ai:spring-ai-milvus-store (Maven): affected from 1.1.0; fixed in 1.1.6
- org.springframework.ai:spring-ai-milvus-store (Maven): affected from 1.1.0; fixed in 1.1.6
- org.springframework.ai:spring-ai-typesense-store (Maven): affected from 1.0.0; fixed in 1.0.7
- org.springframework.ai:spring-ai-typesense-store (Maven): affected from 1.0.0; fixed in 1.0.7
- org.springframework.ai:spring-ai-typesense-store (Maven): affected from 1.1.0; fixed in 1.1.6
- org.springframework.ai:spring-ai-typesense-store (Maven): affected from 1.1.0; fixed in 1.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41705/ (Markdown: https://insights.sbomify.com/CVE-2026-41705/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41705
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41705
- OSV: https://osv.dev/vulnerability/CVE-2026-41705

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41705/
Summaries are generated and may contain mistakes; the official description above is the record.
