# CVE-2026-41706: Open Redirect When Using CookieRequestCache

> Attackers can redirect users to malicious sites after login if CookieRequestCache is enabled, potentially facilitating phishing attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** CLEANSTART-2026-CG72837, CLEANSTART-2026-OR53843, CLEANSTART-2026-XE09130, CLSA-2026-1781484839, CLSA-2026-1785921094, ECHO-8b19-068f-612a, GHSA-x2r2-rvhq-2mqv, MINI-67j6-7qhr-347j, MINI-6wp6-v2rr-jqhm, MINI-7597-9m3m-2683, MINI-8q7g-2cmp-865p, MINI-gmmw-hm7q-595r, MINI-j88j-xmrc-rrqm, MINI-qqxq-p23p-cj56, MINI-v6xx-h3pc-v7fv

## What is CVE-2026-41706?

CVE-2026-41706 is a medium-severity vulnerability in Spring Security, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Spring Security's CookieRequestCache and CookieServerRequestCache store the pre-authentication request URL in a browser cookie so that users can be redirected back to their intended destination after a successful login. In affected versions, the full absolute URL is stored in the cookie and is used without validation as the post-login redirect target.

Affected versions:
Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-41706?

10 open source packages ship an affected version, including org.springframework.security:spring-security-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-web` | Maven | All versions to 5.7.23 | None |
| `org.springframework.security:spring-security-web` | Maven | All versions to 5.7.23 | None |
| `org.springframework.security:spring-security-web` | Maven | From 5.8.0 to 5.8.25 | None |
| `org.springframework.security:spring-security-web` | Maven | From 5.8.0 to 5.8.25 | None |
| `org.springframework.security:spring-security-web` | Maven | From 6.3.0 to 6.3.16 | None |
| `org.springframework.security:spring-security-web` | Maven | From 6.3.0 to 6.3.16 | None |
| `org.springframework.security:spring-security-web` | Maven | From 6.5.0 | 6.5.11 |
| `org.springframework.security:spring-security-web` | Maven | From 6.5.0 | 6.5.11 |
| `org.springframework.security:spring-security-web` | Maven | From 7.0.0 | 7.0.6 |
| `org.springframework.security:spring-security-web` | Maven | From 7.0.0 | 7.0.6 |

Products: Vmware Spring Security.

## How do I fix CVE-2026-41706?

Upgrade org.springframework.security:spring-security-web to a fixed version for your release line: 6.5.11 or 7.0.6.

## Is CVE-2026-41706 being exploited?

There is no known exploitation of CVE-2026-41706 in the wild and no public exploit code.

## Other vulnerabilities in Spring Security

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41706 and fix it if it is affected.

What it is: CVE-2026-41706 is a medium-severity vulnerability in Spring Security, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41706 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-web (Maven): affected all versions up to 5.7.23; no fix listed
- org.springframework.security:spring-security-web (Maven): affected all versions up to 5.7.23; no fix listed
- org.springframework.security:spring-security-web (Maven): affected from 5.8.0 up to 5.8.25; no fix listed
- org.springframework.security:spring-security-web (Maven): affected from 5.8.0 up to 5.8.25; no fix listed
- org.springframework.security:spring-security-web (Maven): affected from 6.3.0 up to 6.3.16; no fix listed
- org.springframework.security:spring-security-web (Maven): affected from 6.3.0 up to 6.3.16; no fix listed
- org.springframework.security:spring-security-web (Maven): affected from 6.5.0; fixed in 6.5.11
- org.springframework.security:spring-security-web (Maven): affected from 6.5.0; fixed in 6.5.11
- org.springframework.security:spring-security-web (Maven): affected from 7.0.0; fixed in 7.0.6
- org.springframework.security:spring-security-web (Maven): affected from 7.0.0; fixed in 7.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41706/ (Markdown: https://insights.sbomify.com/CVE-2026-41706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41706
- OSV: https://osv.dev/vulnerability/CVE-2026-41706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41706/
Summaries are generated and may contain mistakes; the official description above is the record.
