# CVE-2026-41710: Cache Exhaustion in Stateful Retries leads to Denial of Service

> Attackers can exhaust the stateful retry cache with unique failing requests, causing permanent denial of service for retries and circuit breakers.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** CLSA-2026-1786520698, CLSA-2026-1791318628, CLSA-2026-1791320662, CLSA-2026-1791455309, CLSA-2026-1791960902, CLSA-2026-1792010798, CLSA-2026-1792595488, CLSA-2026-1792596227, CLSA-2026-1792596234, CLSA-2026-1792596296, CLSA-2026-1792596369, CLSA-2026-1792596458, CLSA-2026-1792596683, CLSA-2026-1792596994, GHSA-2827-2mxx-j8pv

## What is CVE-2026-41710?

CVE-2026-41710 is a medium-severity denial of service vulnerability in Spring Retry, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An attacker can craft a large number of unique requests that trigger a failure, exhausting the capacity of the application-wide stateful retry cache. Once the cache is full, it permanently rejects any further updates, causing all later stateful retries and circuit breakers in the application to fail.

Affected versions:
Spring Retry 2.0.0 through 2.0.12; 1.3.0 through 1.3.4.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-41710?

4 open source packages ship an affected version, including org.springframework.retry:spring-retry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.retry:spring-retry` | Maven | All versions to 1.3.4 | None |
| `org.springframework.retry:spring-retry` | Maven | All versions to 1.3.4 | None |
| `org.springframework.retry:spring-retry` | Maven | From 2.0.0 | 2.0.13 |
| `org.springframework.retry:spring-retry` | Maven | From 2.0.0 | 2.0.13 |

Products: Broadcom Spring Retry.

## How do I fix CVE-2026-41710?

Upgrade org.springframework.retry:spring-retry to 2.0.13 or later.

## Is CVE-2026-41710 being exploited?

There is no known exploitation of CVE-2026-41710 in the wild and no public exploit code.

Public exploit code:

- spring retry 1.3.x fix with niche toolkit for CVE-2026-41710 (github_poc): https://github.com/NicheToolkit/spring-retry-toolkit

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41710 and fix it if it is affected.

What it is: CVE-2026-41710 is a medium-severity denial of service vulnerability in Spring Retry, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41710 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.retry:spring-retry (Maven): affected all versions up to 1.3.4; no fix listed
- org.springframework.retry:spring-retry (Maven): affected all versions up to 1.3.4; no fix listed
- org.springframework.retry:spring-retry (Maven): affected from 2.0.0; fixed in 2.0.13
- org.springframework.retry:spring-retry (Maven): affected from 2.0.0; fixed in 2.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41710/ (Markdown: https://insights.sbomify.com/CVE-2026-41710/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41710
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41710
- OSV: https://osv.dev/vulnerability/CVE-2026-41710

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41710/
Summaries are generated and may contain mistakes; the official description above is the record.
