CVE-2026-41714 Spring AMQP Core: Missing Certificate and Hostname Verification for amqps URIs in RabbitConnectionFactoryBean

Medium 4.0 Published Updated

Attackers can intercept encrypted traffic because Spring AMQP skips certificate validation when using setUri without explicitly enabling SSL.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41714?

CVE-2026-41714 is a medium-severity vulnerability in Spring AMQP, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Applications that configure their broker connection via RabbitConnectionFactoryBean.setUri("amqps://...") without also calling setUseSSL(true) get TLS encryption with no certificate validation and no hostname verification.

Affected versions: Spring AMQP 4.0.0 through 4.0.3; 3.2.0 through 3.2.10; 3.1.0 through 3.1.15; 2.4.0 through 2.4.17.

Weakness: CWE-295

Which versions are affected by CVE-2026-41714?

8 open source packages ship an affected version, including org.springframework.amqp:spring-amqp. It affects 1 product.

PackageAffectedFixed in
org.springframework.amqp:spring-amqp MavenAll versions to 2.4.17None
org.springframework.amqp:spring-amqp MavenAll versions to 2.4.17None
org.springframework.amqp:spring-amqp MavenFrom 3.1.0 to 3.1.15None
org.springframework.amqp:spring-amqp MavenFrom 3.1.0 to 3.1.15None
org.springframework.amqp:spring-amqp MavenFrom 3.2.03.2.11
org.springframework.amqp:spring-amqp MavenFrom 3.2.03.2.11
2 more packages
org.springframework.amqp:spring-amqp MavenFrom 4.0.04.0.4
org.springframework.amqp:spring-amqp MavenFrom 4.0.04.0.4

Products include Vmware Spring Advanced Message Queuing Protocol.

How do I fix CVE-2026-41714?

Upgrade org.springframework.amqp:spring-amqp to a fixed version for your release line: 3.2.11 or 4.0.4.

Is CVE-2026-41714 being exploited?

There is no known exploitation of CVE-2026-41714 in the wild and no public exploit code.

Sources

Also known as GHSA-p8qj-fj6r-w7q9, ROOT-APP-MAVEN-CVE-2026-41714.

Is CVE-2026-41714 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free