# CVE-2026-41714: Spring AMQP Core: Missing Certificate and Hostname Verification for amqps URIs in RabbitConnectionFactoryBean

> Attackers can intercept encrypted traffic because Spring AMQP skips certificate validation when using setUri without explicitly enabling SSL.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** GHSA-p8qj-fj6r-w7q9, ROOT-APP-MAVEN-CVE-2026-41714

## What is CVE-2026-41714?

CVE-2026-41714 is a medium-severity vulnerability in Spring AMQP, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Applications that configure their broker connection via RabbitConnectionFactoryBean.setUri("amqps://...") without also calling setUseSSL(true) get TLS encryption with no certificate validation and no hostname verification.

Affected versions:
Spring AMQP 4.0.0 through 4.0.3; 3.2.0 through 3.2.10; 3.1.0 through 3.1.15; 2.4.0 through 2.4.17.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-41714?

8 open source packages ship an affected version, including org.springframework.amqp:spring-amqp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.amqp:spring-amqp` | Maven | All versions to 2.4.17 | None |
| `org.springframework.amqp:spring-amqp` | Maven | All versions to 2.4.17 | None |
| `org.springframework.amqp:spring-amqp` | Maven | From 3.1.0 to 3.1.15 | None |
| `org.springframework.amqp:spring-amqp` | Maven | From 3.1.0 to 3.1.15 | None |
| `org.springframework.amqp:spring-amqp` | Maven | From 3.2.0 | 3.2.11 |
| `org.springframework.amqp:spring-amqp` | Maven | From 3.2.0 | 3.2.11 |
| `org.springframework.amqp:spring-amqp` | Maven | From 4.0.0 | 4.0.4 |
| `org.springframework.amqp:spring-amqp` | Maven | From 4.0.0 | 4.0.4 |

Products: Vmware Spring Advanced Message Queuing Protocol.

## How do I fix CVE-2026-41714?

Upgrade org.springframework.amqp:spring-amqp to a fixed version for your release line: 3.2.11 or 4.0.4.

## Is CVE-2026-41714 being exploited?

There is no known exploitation of CVE-2026-41714 in the wild and no public exploit code.

## Other vulnerabilities in Spring AMQP

- [CVE-2026-59272](https://insights.sbomify.com/CVE-2026-59272/): Log4j2 AmqpAppender disables TLS hostname verification by default (medium 6.8)
- [CVE-2026-59275](https://insights.sbomify.com/CVE-2026-59275/): Deserialization in Spring AMQP (medium 6.6)
- [CVE-2026-59320](https://insights.sbomify.com/CVE-2026-59320/): In Spring AMQP the link credit never replenished on listener exception path (medium 6.5)
- [CVE-2026-47860](https://insights.sbomify.com/CVE-2026-47860/): Unbounded decompression of attacker-supplied compressed message bodies (medium 6.5)
- [CVE-2021-22095](https://insights.sbomify.com/CVE-2021-22095/): Deserialization of Untrusted Data in Spring AMQP (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41714 and fix it if it is affected.

What it is: CVE-2026-41714 is a medium-severity vulnerability in Spring AMQP, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41714 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.amqp:spring-amqp (Maven): affected all versions up to 2.4.17; no fix listed
- org.springframework.amqp:spring-amqp (Maven): affected all versions up to 2.4.17; no fix listed
- org.springframework.amqp:spring-amqp (Maven): affected from 3.1.0 up to 3.1.15; no fix listed
- org.springframework.amqp:spring-amqp (Maven): affected from 3.1.0 up to 3.1.15; no fix listed
- org.springframework.amqp:spring-amqp (Maven): affected from 3.2.0; fixed in 3.2.11
- org.springframework.amqp:spring-amqp (Maven): affected from 3.2.0; fixed in 3.2.11
- org.springframework.amqp:spring-amqp (Maven): affected from 4.0.0; fixed in 4.0.4
- org.springframework.amqp:spring-amqp (Maven): affected from 4.0.0; fixed in 4.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41714/ (Markdown: https://insights.sbomify.com/CVE-2026-41714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41714
- OSV: https://osv.dev/vulnerability/CVE-2026-41714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41714/
Summaries are generated and may contain mistakes; the official description above is the record.
