{"answers":{"affected":"8 open source packages ship an affected version, including io.projectreactor.netty:reactor-netty.","exploited":"There is no known exploitation of CVE-2026-41715 in the wild and no public exploit code.","fix":"Upgrade io.projectreactor.netty:reactor-netty to a fixed version for your release line: 1.2.18 or 1.3.6.","what":"CVE-2026-41715 is a medium-severity vulnerability in Spring Reactor Netty, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-41715 and fix it if it is affected.\n\nWhat it is: CVE-2026-41715 is a medium-severity vulnerability in Spring Reactor Netty, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-41715 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.projectreactor.netty:reactor-netty (Maven): affected from 1.0.0 up to 1.0.48; no fix listed\n- io.projectreactor.netty:reactor-netty (Maven): affected from 1.0.0 up to 1.0.48; no fix listed\n- io.projectreactor.netty:reactor-netty (Maven): affected from 1.1.0 up to 1.1.31; no fix listed\n- io.projectreactor.netty:reactor-netty (Maven): affected from 1.1.0 up to 1.1.31; no fix listed\n- io.projectreactor.netty:reactor-netty (Maven): affected from 1.2.0; fixed in 1.2.18\n- io.projectreactor.netty:reactor-netty (Maven): affected from 1.2.0; fixed in 1.2.18\n- io.projectreactor.netty:reactor-netty (Maven): affected from 1.3.0; fixed in 1.3.6\n- io.projectreactor.netty:reactor-netty (Maven): affected from 1.3.0; fixed in 1.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41715/ (Markdown: https://insights.sbomify.com/CVE-2026-41715/index.md)","id":"CVE-2026-41715","markdown":"https://insights.sbomify.com/CVE-2026-41715/index.md","name":"CVE-2026-41715","record":{"aliases":["CLEANSTART-2026-RO34995","CLSA-2026-1783645392","CLSA-2026-1783645399","CLSA-2026-1784769563","CLSA-2026-1786940280","CLSA-2026-1788524080","CLSA-2026-1789459160","CLSA-2026-1792575065","GHSA-pfc9-2cqg-9wq6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Java HTTP client library","requires_auth":"none","summary":"Attackers can steal credentials when Reactor Netty follows redirects from HTTPS to HTTP, requiring explicit redirect configuration.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"vmware","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"In specific scenarios involving HTTP redirects from a secure to an insecure endpoint, the Reactor Netty HTTP client may leak credentials. In order for this to happen, the HTTP client must have been explicitly configured to follow redirects.\n\nAffected versions:\nReactor Netty 1.0.0 through 1.0.51; 1.1.0 through 1.1.35; 1.2.0 through 1.2.17; 1.3.0 through 1.3.5.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reactor Netty HTTP Client Leaks Credentials On Protocol Downgrade Redirect","id":"CVE-2026-41715","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":8,"n_references":1,"next":{"headline":"Spring Data web support unbounded negative-result cache keyed on attacker-supplied property names","id":"CVE-2026-41716"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["1.0.0"],"last_affected":["1.0.48"],"package":"io.projectreactor.netty:reactor-netty","purl":null,"source":"GHSA-pfc9-2cqg-9wq6"},{"ecosystem":"Maven","fixed":[],"introduced":["1.0.0"],"last_affected":["1.0.48"],"package":"io.projectreactor.netty:reactor-netty","purl":"pkg:maven/io.projectreactor.netty/reactor-netty","source":"GHSA-pfc9-2cqg-9wq6"},{"ecosystem":"Maven","fixed":[],"introduced":["1.1.0"],"last_affected":["1.1.31"],"package":"io.projectreactor.netty:reactor-netty","purl":null,"source":"GHSA-pfc9-2cqg-9wq6"},{"ecosystem":"Maven","fixed":[],"introduced":["1.1.0"],"last_affected":["1.1.31"],"package":"io.projectreactor.netty:reactor-netty","purl":"pkg:maven/io.projectreactor.netty/reactor-netty","source":"GHSA-pfc9-2cqg-9wq6"},{"ecosystem":"Maven","fixed":["1.2.18"],"introduced":["1.2.0"],"last_affected":[],"package":"io.projectreactor.netty:reactor-netty","purl":null,"source":"GHSA-pfc9-2cqg-9wq6"},{"ecosystem":"Maven","fixed":["1.2.18"],"introduced":["1.2.0"],"last_affected":[],"package":"io.projectreactor.netty:reactor-netty","purl":"pkg:maven/io.projectreactor.netty/reactor-netty","source":"GHSA-pfc9-2cqg-9wq6"},{"ecosystem":"Maven","fixed":["1.3.6"],"introduced":["1.3.0"],"last_affected":[],"package":"io.projectreactor.netty:reactor-netty","purl":null,"source":"GHSA-pfc9-2cqg-9wq6"},{"ecosystem":"Maven","fixed":["1.3.6"],"introduced":["1.3.0"],"last_affected":[],"package":"io.projectreactor.netty:reactor-netty","purl":"pkg:maven/io.projectreactor.netty/reactor-netty","source":"GHSA-pfc9-2cqg-9wq6"}],"prev":{"headline":"Spring AMQP Core: Missing Certificate and Hostname Verification for amqps URIs in RabbitConnectionFactoryBean","id":"CVE-2026-41714"},"products":["Reactor Netty"],"published":"2026-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["Spring"]},"summary":"Attackers can steal credentials when Reactor Netty follows redirects from HTTPS to HTTP, requiring explicit redirect configuration.","url":"https://insights.sbomify.com/CVE-2026-41715/"}