# CVE-2026-41715: Reactor Netty HTTP Client Leaks Credentials On Protocol Downgrade Redirect

> Attackers can steal credentials when Reactor Netty follows redirects from HTTPS to HTTP, requiring explicit redirect configuration.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** CLEANSTART-2026-RO34995, CLSA-2026-1783645392, CLSA-2026-1783645399, CLSA-2026-1784769563, CLSA-2026-1786940280, CLSA-2026-1788524080, CLSA-2026-1789459160, CLSA-2026-1792575065, GHSA-pfc9-2cqg-9wq6

## What is CVE-2026-41715?

CVE-2026-41715 is a medium-severity vulnerability in Spring Reactor Netty, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In specific scenarios involving HTTP redirects from a secure to an insecure endpoint, the Reactor Netty HTTP client may leak credentials. In order for this to happen, the HTTP client must have been explicitly configured to follow redirects.

Affected versions:
Reactor Netty 1.0.0 through 1.0.51; 1.1.0 through 1.1.35; 1.2.0 through 1.2.17; 1.3.0 through 1.3.5.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2026-41715?

8 open source packages ship an affected version, including io.projectreactor.netty:reactor-netty.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.projectreactor.netty:reactor-netty` | Maven | From 1.0.0 to 1.0.48 | None |
| `io.projectreactor.netty:reactor-netty` | Maven | From 1.0.0 to 1.0.48 | None |
| `io.projectreactor.netty:reactor-netty` | Maven | From 1.1.0 to 1.1.31 | None |
| `io.projectreactor.netty:reactor-netty` | Maven | From 1.1.0 to 1.1.31 | None |
| `io.projectreactor.netty:reactor-netty` | Maven | From 1.2.0 | 1.2.18 |
| `io.projectreactor.netty:reactor-netty` | Maven | From 1.2.0 | 1.2.18 |
| `io.projectreactor.netty:reactor-netty` | Maven | From 1.3.0 | 1.3.6 |
| `io.projectreactor.netty:reactor-netty` | Maven | From 1.3.0 | 1.3.6 |

## How do I fix CVE-2026-41715?

Upgrade io.projectreactor.netty:reactor-netty to a fixed version for your release line: 1.2.18 or 1.3.6.

## Is CVE-2026-41715 being exploited?

There is no known exploitation of CVE-2026-41715 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41715 and fix it if it is affected.

What it is: CVE-2026-41715 is a medium-severity vulnerability in Spring Reactor Netty, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41715 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.projectreactor.netty:reactor-netty (Maven): affected from 1.0.0 up to 1.0.48; no fix listed
- io.projectreactor.netty:reactor-netty (Maven): affected from 1.0.0 up to 1.0.48; no fix listed
- io.projectreactor.netty:reactor-netty (Maven): affected from 1.1.0 up to 1.1.31; no fix listed
- io.projectreactor.netty:reactor-netty (Maven): affected from 1.1.0 up to 1.1.31; no fix listed
- io.projectreactor.netty:reactor-netty (Maven): affected from 1.2.0; fixed in 1.2.18
- io.projectreactor.netty:reactor-netty (Maven): affected from 1.2.0; fixed in 1.2.18
- io.projectreactor.netty:reactor-netty (Maven): affected from 1.3.0; fixed in 1.3.6
- io.projectreactor.netty:reactor-netty (Maven): affected from 1.3.0; fixed in 1.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41715/ (Markdown: https://insights.sbomify.com/CVE-2026-41715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41715
- OSV: https://osv.dev/vulnerability/CVE-2026-41715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41715/
Summaries are generated and may contain mistakes; the official description above is the record.
