CVE-2026-41721 Spring Data Commons Denial of Service via Data Binding
Attackers can cause denial of service via memory exhaustion in Spring Data Commons when using @ProjectedPayload with web support enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41721?
CVE-2026-41721 is a medium-severity denial of service vulnerability in Spring Data Commons, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Spring Data Commons contains a vulnerability that can lead to a Denial of Service (DoS) condition if Spring Data Web Support is enabled in conjunction with a Controller method using @ProjectedPayload, when an attacker sends a specially crafted HTTP request that causes the application to allocate lots of memory.
Affected versions: Spring Data Commons 4.0.0 through 4.0.5; 3.5.0 through 3.5.11; 3.4.0 through 3.4.14; 3.3.0 through 3.3.16; 3.2.0 through 3.2.15; 3.1.0 through 3.1.14; 3.0.0 through 3.0.15; 2.7.0 through 2.7.19.
Weakness: CWE-400
Which versions are affected by CVE-2026-41721?
10 open source packages ship an affected version, including org.springframework.data:spring-data-commons. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.data:spring-data-commons Maven | All versions to 2.7.19 | None |
org.springframework.data:spring-data-commons Maven | All versions to 2.7.19 | None |
org.springframework.data:spring-data-commons Maven | From 3.0.0 to 3.3.16 | None |
org.springframework.data:spring-data-commons Maven | From 3.0.0 to 3.3.16 | None |
org.springframework.data:spring-data-commons Maven | From 3.4.0 to 3.4.14 | None |
org.springframework.data:spring-data-commons Maven | From 3.4.0 to 3.4.14 | None |
4 more packages
org.springframework.data:spring-data-commons Maven | From 3.5.0 | 3.5.12 |
org.springframework.data:spring-data-commons Maven | From 3.5.0 | 3.5.12 |
org.springframework.data:spring-data-commons Maven | From 4.0.0 | 4.0.6 |
org.springframework.data:spring-data-commons Maven | From 4.0.0 | 4.0.6 |
Products include Broadcom Spring Data Commons.
How do I fix CVE-2026-41721?
Upgrade org.springframework.data:spring-data-commons to a fixed version for your release line: 3.5.12 or 4.0.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-41721 being exploited?
There is no known exploitation of CVE-2026-41721 in the wild and no public exploit code.
Other vulnerabilities in Spring Data Commons
- CVE-2026-41695 Denial of Service in Spring Data Commons Property Path Resolution
- CVE-2026-41716 Spring Data web support unbounded negative-result cache keyed on attacker-supplied property names
- CVE-2018-1259 Spring Data Commons, used in combination with XMLBeam, contains a property binder vulnerability caused by improper restriction of XML external entity references
- CVE-2018-1274 Spring Data Commons contain a property path parser vulnerability caused by unlimited resource allocation
- CVE-2026-41711 Potential Denial of Service through crafted Sort Parameters
Sources
Also known as CLEANSTART-2026-CJ74224, CLEANSTART-2026-UZ46402, CLEANSTART-2026-VJ67556, CLSA-2026-1791974541, GHSA-5m4m-73w9-8433, MINI-5563-g6hq-87g9 and 2 more.