# CVE-2026-41727: In Spring for Apache Kafka, forged retry topic headers subvert retry routing and backoff behavior

> Attackers can manipulate retry topic routing and backoff behavior by sending crafted headers, disrupting message processing logic in Spring Kafka applications.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** GHSA-53w6-v7cv-fc9h, MINI-3hj8-m4vp-4973, MINI-qqv4-497r-8c29

## What is CVE-2026-41727?

CVE-2026-41727 is a medium-severity vulnerability in Spring for Apache Kafka, published on 9 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Spring Kafka's retry topic infrastructure did not sufficiently validate user-controlled header values before acting on them. A producer could send a record with a crafted retry_topic-attempts header to supply an out-of-range attempt count and cause the retry topic router to misidentify where the message was in the retry sequence.

Affected versions:
Spring for Apache Kafka 4.0.0 through 4.0.5; 3.3.0 through 3.3.15; 3.2.0 through 3.2.13; 2.9.0 through 2.9.13; 2.8.0 through 2.8.11.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-41727?

10 open source packages ship an affected version, including org.springframework.kafka:spring-kafka. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.kafka:spring-kafka` | Maven | All versions to 2.8.11 | None |
| `org.springframework.kafka:spring-kafka` | Maven | All versions to 2.8.11 | None |
| `org.springframework.kafka:spring-kafka` | Maven | From 2.9.0 to 2.9.13 | None |
| `org.springframework.kafka:spring-kafka` | Maven | From 2.9.0 to 2.9.13 | None |
| `org.springframework.kafka:spring-kafka` | Maven | From 3.2.0 to 3.2.13 | None |
| `org.springframework.kafka:spring-kafka` | Maven | From 3.2.0 to 3.2.13 | None |
| `org.springframework.kafka:spring-kafka` | Maven | From 3.3.0 | 3.3.16 |
| `org.springframework.kafka:spring-kafka` | Maven | From 3.3.0 | 3.3.16 |
| `org.springframework.kafka:spring-kafka` | Maven | From 4.0.0 | 4.0.6 |
| `org.springframework.kafka:spring-kafka` | Maven | From 4.0.0 | 4.0.6 |

Products: Vmware Spring for Apache Kafka.

## How do I fix CVE-2026-41727?

Upgrade org.springframework.kafka:spring-kafka to a fixed version for your release line: 3.3.16 or 4.0.6.

## Is CVE-2026-41727 being exploited?

There is no known exploitation of CVE-2026-41727 in the wild and no public exploit code.

## Other vulnerabilities in Spring for Apache Kafka

- [CVE-2026-59278](https://insights.sbomify.com/CVE-2026-59278/): Server-side request forgery in Spring for Apache Kafka (medium 6.5)
- [CVE-2026-59317](https://insights.sbomify.com/CVE-2026-59317/): Denial of service in Spring for Apache Kafka (medium 6.5)
- [CVE-2026-41726](https://insights.sbomify.com/CVE-2026-41726/): In Spring for Apache Kafka, unbounded delegate cache keyed on user-controlled, potentially malicious selector header (medium 6.5)
- [CVE-2023-34040](https://insights.sbomify.com/CVE-2023-34040/): Java Deserialization vulnerability in Spring-Kafka When Improperly Configured (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41727 and fix it if it is affected.

What it is: CVE-2026-41727 is a medium-severity vulnerability in Spring for Apache Kafka, published on 9 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41727 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.kafka:spring-kafka (Maven): affected all versions up to 2.8.11; no fix listed
- org.springframework.kafka:spring-kafka (Maven): affected all versions up to 2.8.11; no fix listed
- org.springframework.kafka:spring-kafka (Maven): affected from 2.9.0 up to 2.9.13; no fix listed
- org.springframework.kafka:spring-kafka (Maven): affected from 2.9.0 up to 2.9.13; no fix listed
- org.springframework.kafka:spring-kafka (Maven): affected from 3.2.0 up to 3.2.13; no fix listed
- org.springframework.kafka:spring-kafka (Maven): affected from 3.2.0 up to 3.2.13; no fix listed
- org.springframework.kafka:spring-kafka (Maven): affected from 3.3.0; fixed in 3.3.16
- org.springframework.kafka:spring-kafka (Maven): affected from 3.3.0; fixed in 3.3.16
- org.springframework.kafka:spring-kafka (Maven): affected from 4.0.0; fixed in 4.0.6
- org.springframework.kafka:spring-kafka (Maven): affected from 4.0.0; fixed in 4.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41727/ (Markdown: https://insights.sbomify.com/CVE-2026-41727/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41727
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41727
- OSV: https://osv.dev/vulnerability/CVE-2026-41727

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41727/
Summaries are generated and may contain mistakes; the official description above is the record.
