CVE-2026-41730 Spring Data REST exposes persistence-layer internals in error responses

Medium 5.3 Published Updated

Attackers can view internal persistence-layer details via HTTP error responses, potentially aiding further attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41730?

CVE-2026-41730 is a medium-severity vulnerability in Spring Data REST, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Spring Data REST serializes the full exception cause chain into HTTP error response bodies, potentially exposing persistence-layer internals to HTTP clients.

Affected versions: Spring Data REST 3.7.0 through 3.7.19; 4.3.0 through 4.3.16; 4.4.0 through 4.4.14; 4.5.0 through 4.5.11; 5.0.0 through 5.0.5.

Weakness: CWE-209

Which versions are affected by CVE-2026-41730?

10 open source packages ship an affected version, including org.springframework.data:spring-data-rest-core. It affects 1 product.

PackageAffectedFixed in
org.springframework.data:spring-data-rest-core MavenAll versions to 3.7.19None
org.springframework.data:spring-data-rest-core MavenAll versions to 3.7.19None
org.springframework.data:spring-data-rest-core MavenFrom 4.3.0 to 4.3.16None
org.springframework.data:spring-data-rest-core MavenFrom 4.3.0 to 4.3.16None
org.springframework.data:spring-data-rest-core MavenFrom 4.4.0 to 4.4.14None
org.springframework.data:spring-data-rest-core MavenFrom 4.4.0 to 4.4.14None
4 more packages
org.springframework.data:spring-data-rest-core MavenFrom 4.5.04.5.12
org.springframework.data:spring-data-rest-core MavenFrom 4.5.04.5.12
org.springframework.data:spring-data-rest-core MavenFrom 5.0.05.0.6
org.springframework.data:spring-data-rest-core MavenFrom 5.0.05.0.6

Products include Vmware Spring Data Rest.

How do I fix CVE-2026-41730?

Upgrade org.springframework.data:spring-data-rest-core to a fixed version for your release line: 4.5.12 or 5.0.6.

Is CVE-2026-41730 being exploited?

There is no known exploitation of CVE-2026-41730 in the wild and no public exploit code.

Sources

Also known as GHSA-p5mm-xwgq-whfr.

Is CVE-2026-41730 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free