{"answers":{"affected":"6 open source packages ship an affected version, including org.springframework.pulsar:spring-pulsar. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-41732 in the wild and no public exploit code.","fix":"Upgrade org.springframework.pulsar:spring-pulsar to a fixed version for your release line: 1.2.18 or 2.0.6.","what":"CVE-2026-41732 is a high-severity unsafe deserialization vulnerability in Spring for Apache Pulsar, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41732 and fix it if it is affected.\n\nWhat it is: CVE-2026-41732 is a high-severity unsafe deserialization vulnerability in Spring for Apache Pulsar, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-41732 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.springframework.pulsar:spring-pulsar (Maven): affected all versions up to 1.1.17; no fix listed\n- org.springframework.pulsar:spring-pulsar (Maven): affected all versions up to 1.1.17; no fix listed\n- org.springframework.pulsar:spring-pulsar (Maven): affected from 1.2.0; fixed in 1.2.18\n- org.springframework.pulsar:spring-pulsar (Maven): affected from 1.2.0; fixed in 1.2.18\n- org.springframework.pulsar:spring-pulsar (Maven): affected from 2.0.0; fixed in 2.0.6\n- org.springframework.pulsar:spring-pulsar (Maven): affected from 2.0.0; fixed in 2.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41732/ (Markdown: https://insights.sbomify.com/CVE-2026-41732/index.md)","id":"CVE-2026-41732","markdown":"https://insights.sbomify.com/CVE-2026-41732/index.md","name":"CVE-2026-41732","record":{"aliases":["CLSA-2026-1788508154","CLSA-2026-1790933698","CLSA-2026-1792130659","CLSA-2026-1792598107","GHSA-gg69-9wwp-6jx2","ROOT-APP-MAVEN-CVE-2026-41732"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Spring for Apache Pulsar","requires_auth":"none","summary":"Attackers can achieve remote code execution via unsafe deserialization in Spring for Apache Pulsar due to overly broad trusted-package matching.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"vmware","cpe":[{"product":"spring_for_apache_pulsar","vendor":"vmware"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"JsonPulsarHeaderMapper matched type headers against trusted packages using a prefix check, meaning that trusting any package implicitly trusted all of its subpackages. Additionally, an empty trusted-packages configuration fell back to trusting all packages rather than applying a safe default allow-list.\n\nAffected versions:\nSpring for Apache Pulsar 2.0.0 through 2.0.5; 1.2.0 through 1.2.17; 1.1.0 through 1.1.17.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Spring for Apache Pulsar: JsonPulsarHeaderMapper Trusted-Package Prefix Check Allows Unintended Subpackage Deserialization","id":"CVE-2026-41732","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":6,"n_references":1,"next":{"headline":"Spring Data REST Querydsl integration exposes Jackson-hidden persistent fields as filter keys","id":"CVE-2026-41837"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["1.1.17"],"package":"org.springframework.pulsar:spring-pulsar","purl":null,"source":"GHSA-gg69-9wwp-6jx2"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["1.1.17"],"package":"org.springframework.pulsar:spring-pulsar","purl":"pkg:maven/org.springframework.pulsar/spring-pulsar","source":"GHSA-gg69-9wwp-6jx2"},{"ecosystem":"Maven","fixed":["1.2.18"],"introduced":["1.2.0"],"last_affected":[],"package":"org.springframework.pulsar:spring-pulsar","purl":null,"source":"GHSA-gg69-9wwp-6jx2"},{"ecosystem":"Maven","fixed":["1.2.18"],"introduced":["1.2.0"],"last_affected":[],"package":"org.springframework.pulsar:spring-pulsar","purl":"pkg:maven/org.springframework.pulsar/spring-pulsar","source":"GHSA-gg69-9wwp-6jx2"},{"ecosystem":"Maven","fixed":["2.0.6"],"introduced":["2.0.0"],"last_affected":[],"package":"org.springframework.pulsar:spring-pulsar","purl":null,"source":"GHSA-gg69-9wwp-6jx2"},{"ecosystem":"Maven","fixed":["2.0.6"],"introduced":["2.0.0"],"last_affected":[],"package":"org.springframework.pulsar:spring-pulsar","purl":"pkg:maven/org.springframework.pulsar/spring-pulsar","source":"GHSA-gg69-9wwp-6jx2"}],"prev":{"headline":"In Spring for Apache Kafka, overly broad trusted-package matching in header mappers exposes JDK classes to deserialization","id":"CVE-2026-41731"},"products":["Spring for Apache Pulsar"],"published":"2026-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-27","vendors":["Spring"]},"summary":"Attackers can achieve remote code execution via unsafe deserialization in Spring for Apache Pulsar due to overly broad trusted-package matching.","url":"https://insights.sbomify.com/CVE-2026-41732/"}