# CVE-2026-41732: Spring for Apache Pulsar: JsonPulsarHeaderMapper Trusted-Package Prefix Check Allows Unintended Subpackage Deserialization

> Attackers can achieve remote code execution via unsafe deserialization in Spring for Apache Pulsar due to overly broad trusted-package matching.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** CLSA-2026-1788508154, CLSA-2026-1790933698, CLSA-2026-1792130659, CLSA-2026-1792598107, GHSA-gg69-9wwp-6jx2, ROOT-APP-MAVEN-CVE-2026-41732

## What is CVE-2026-41732?

CVE-2026-41732 is a high-severity unsafe deserialization vulnerability in Spring for Apache Pulsar, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JsonPulsarHeaderMapper matched type headers against trusted packages using a prefix check, meaning that trusting any package implicitly trusted all of its subpackages. Additionally, an empty trusted-packages configuration fell back to trusting all packages rather than applying a safe default allow-list.

Affected versions:
Spring for Apache Pulsar 2.0.0 through 2.0.5; 1.2.0 through 1.2.17; 1.1.0 through 1.1.17.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-41732?

6 open source packages ship an affected version, including org.springframework.pulsar:spring-pulsar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.pulsar:spring-pulsar` | Maven | All versions to 1.1.17 | None |
| `org.springframework.pulsar:spring-pulsar` | Maven | All versions to 1.1.17 | None |
| `org.springframework.pulsar:spring-pulsar` | Maven | From 1.2.0 | 1.2.18 |
| `org.springframework.pulsar:spring-pulsar` | Maven | From 1.2.0 | 1.2.18 |
| `org.springframework.pulsar:spring-pulsar` | Maven | From 2.0.0 | 2.0.6 |
| `org.springframework.pulsar:spring-pulsar` | Maven | From 2.0.0 | 2.0.6 |

Products: Vmware Spring for Apache Pulsar.

## How do I fix CVE-2026-41732?

Upgrade org.springframework.pulsar:spring-pulsar to a fixed version for your release line: 1.2.18 or 2.0.6.

## Is CVE-2026-41732 being exploited?

There is no known exploitation of CVE-2026-41732 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41732 and fix it if it is affected.

What it is: CVE-2026-41732 is a high-severity unsafe deserialization vulnerability in Spring for Apache Pulsar, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41732 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.pulsar:spring-pulsar (Maven): affected all versions up to 1.1.17; no fix listed
- org.springframework.pulsar:spring-pulsar (Maven): affected all versions up to 1.1.17; no fix listed
- org.springframework.pulsar:spring-pulsar (Maven): affected from 1.2.0; fixed in 1.2.18
- org.springframework.pulsar:spring-pulsar (Maven): affected from 1.2.0; fixed in 1.2.18
- org.springframework.pulsar:spring-pulsar (Maven): affected from 2.0.0; fixed in 2.0.6
- org.springframework.pulsar:spring-pulsar (Maven): affected from 2.0.0; fixed in 2.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41732/ (Markdown: https://insights.sbomify.com/CVE-2026-41732/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41732
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41732
- OSV: https://osv.dev/vulnerability/CVE-2026-41732

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41732/
Summaries are generated and may contain mistakes; the official description above is the record.
