{"answers":{"affected":"2 open source packages ship an affected version, including aureuserp/aureuserp.","exploited":"There is no known exploitation of CVE-2026-4175 in the wild and no public exploit code.","fix":"Upgrade aureuserp/aureuserp to 1.3.0-BETA1 or later.","what":"CVE-2026-4175 is a medium-severity cross-site scripting vulnerability in Aureus ERP, published on 15 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-4175 and fix it if it is affected.\n\nWhat it is: CVE-2026-4175 is a medium-severity cross-site scripting vulnerability in Aureus ERP, published on 15 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-4175 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aureuserp/aureuserp (Packagist): affected all versions; fixed in 1.3.0-BETA1\n- aureuserp/aureuserp (Packagist): affected all versions; fixed in 1.3.0-BETA1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-4175/ (Markdown: https://insights.sbomify.com/CVE-2026-4175/index.md)","id":"CVE-2026-4175","markdown":"https://insights.sbomify.com/CVE-2026-4175/index.md","name":"CVE-2026-4175","record":{"aliases":["GHSA-76c2-3q6g-xvpm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Aureus ERP","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via Chatter Message content, potentially leading to code execution or account takeover in Aureus ERP.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was determined in Aureus ERP up to 1.3.0-BETA2. The affected element is an unknown function of the file plugins/webkul/chatter/resources/views/filament/infolists/components/messages/content-text-entry.blade.php of the component Chatter Message Handler. Executing a manipulation of the argument subject/body can lead to cross site scripting. The attack can be launched remotely. Upgrading to version 1.3.0-BETA1 is sufficient to fix this issue. This patch is called 2135ee7efff4090e70050b63015ab5e268760ec8. It is suggested to upgrade the affected component.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Aureus ERP Chatter Message content-text-entry.blade.php cross site scripting","id":"CVE-2026-4175","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":6,"next":{"headline":"Supply chain in perl","id":"CVE-2026-4176"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.0-BETA1"],"introduced":["0"],"last_affected":[],"package":"aureuserp/aureuserp","purl":null,"source":"GHSA-76c2-3q6g-xvpm"},{"ecosystem":"Packagist","fixed":["1.3.0-BETA1"],"introduced":["0"],"last_affected":[],"package":"aureuserp/aureuserp","purl":"pkg:composer/aureuserp/aureuserp","source":"GHSA-76c2-3q6g-xvpm"}],"prev":{"headline":"Radare2 Mach-O File mach0.c walk_exports_trie resource consumption","id":"CVE-2026-4174"},"products":["ERP"],"published":"2026-03-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-17","vendors":["Aureus"]},"summary":"Remote attackers can inject malicious scripts via Chatter Message content, potentially leading to code execution or account takeover in Aureus ERP.","url":"https://insights.sbomify.com/CVE-2026-4175/"}