# CVE-2026-4175: Aureus ERP Chatter Message content-text-entry.blade.php cross site scripting

> Remote attackers can inject malicious scripts via Chatter Message content, potentially leading to code execution or account takeover in Aureus ERP.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Mar 2026
- **Updated:** 17 Mar 2026
- **Also known as:** GHSA-76c2-3q6g-xvpm

## What is CVE-2026-4175?

CVE-2026-4175 is a medium-severity cross-site scripting vulnerability in Aureus ERP, published on 15 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was determined in Aureus ERP up to 1.3.0-BETA2. The affected element is an unknown function of the file plugins/webkul/chatter/resources/views/filament/infolists/components/messages/content-text-entry.blade.php of the component Chatter Message Handler. Executing a manipulation of the argument subject/body can lead to cross site scripting. The attack can be launched remotely. Upgrading to version 1.3.0-BETA1 is sufficient to fix this issue. This patch is called 2135ee7efff4090e70050b63015ab5e268760ec8. It is suggested to upgrade the affected component.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-4175?

2 open source packages ship an affected version, including aureuserp/aureuserp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aureuserp/aureuserp` | Packagist | All versions | 1.3.0-BETA1 |
| `aureuserp/aureuserp` | Packagist | All versions | 1.3.0-BETA1 |

## How do I fix CVE-2026-4175?

Upgrade aureuserp/aureuserp to 1.3.0-BETA1 or later.

## Is CVE-2026-4175 being exploited?

There is no known exploitation of CVE-2026-4175 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4175 and fix it if it is affected.

What it is: CVE-2026-4175 is a medium-severity cross-site scripting vulnerability in Aureus ERP, published on 15 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-4175 in the wild and no public exploit code.

Affected packages and fixed versions:
- aureuserp/aureuserp (Packagist): affected all versions; fixed in 1.3.0-BETA1
- aureuserp/aureuserp (Packagist): affected all versions; fixed in 1.3.0-BETA1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4175/ (Markdown: https://insights.sbomify.com/CVE-2026-4175/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4175
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4175
- OSV: https://osv.dev/vulnerability/CVE-2026-4175

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4175/
Summaries are generated and may contain mistakes; the official description above is the record.
