CVE-2026-4176 Supply chain in perl
Perl includes a vulnerable vendored zlib in Compress::Raw::Zlib, allowing attackers to exploit underlying zlib flaws like code execution or DoS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-4176?
CVE-2026-4176 is a critical vulnerability in SHAY perl, published on 29 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerable version of Compress::Raw::Zlib.
Compress::Raw::Zlib is included in the Perl package as a dual-life core module, and is vulnerable to CVE-2026-3381 due to a vendored version of zlib which has several vulnerabilities, including CVE-2026-27171. The bundled Compress::Raw::Zlib was updated to version 2.221 in Perl blead commit c75ae9cc164205e1b6d6dbd57bd2c65c8593fe94.
Weakness: CWE-1395
Which versions are affected by CVE-2026-4176?
It affects 1 product.
Products include Perl Perl.
How do I fix CVE-2026-4176?
Upgrade to a fixed version.
Is CVE-2026-4176 being exploited?
There is no known exploitation of CVE-2026-4176 in the wild and no public exploit code.
Other vulnerabilities in SHAY perl
Sources
Also known as ALPINE-CVE-2026-4176, AZL-81309, AZL-81318, AZL-81321, AZL-81327, AZL-81339 and 9 more.