{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-4176 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-4176 is a critical vulnerability in SHAY perl, published on 29 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-4176 and fix it if it is affected.\n\nWhat it is: CVE-2026-4176 is a critical vulnerability in SHAY perl, published on 29 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-4176 in the wild and no public exploit code.\n\nAffected product: SHAY perl. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-4176/ (Markdown: https://insights.sbomify.com/CVE-2026-4176/index.md)","id":"CVE-2026-4176","markdown":"https://insights.sbomify.com/CVE-2026-4176/index.md","name":"CVE-2026-4176","record":{"aliases":["ALPINE-CVE-2026-4176","AZL-81309","AZL-81318","AZL-81321","AZL-81327","AZL-81339","AZL-81342","AZL-81351","DEBIAN-CVE-2026-4176","GHSA-q2q4-jjp8-f6m3","MINI-6wh3-hgvx-4vq2","MINI-f9vm-mg6q-rmx5","MINI-jhq7-wr7v-jx45","MINI-r5mq-vf37-j5p9","UBUNTU-CVE-2026-4176"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl core module","requires_auth":"none","summary":"Perl includes a vulnerable vendored zlib in Compress::Raw::Zlib, allowing attackers to exploit underlying zlib flaws like code execution or DoS.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CPANSec","cpe":[{"product":"perl","vendor":"perl"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1395","name":"Dependency on Vulnerable Third-Party Component"}],"description":"Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerable version of Compress::Raw::Zlib.\n\nCompress::Raw::Zlib is included in the Perl package as a dual-life core module, and is vulnerable to CVE-2026-3381 due to a vendored version of zlib which has several vulnerabilities, including CVE-2026-27171. The bundled Compress::Raw::Zlib was updated to version 2.221 in Perl blead commit c75ae9cc164205e1b6d6dbd57bd2c65c8593fe94.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Supply chain in perl","id":"CVE-2026-4176","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"supply_chain","year":"2026"},"n_packages":0,"n_references":6,"next":{"headline":"Memory corruption in YAML::Syck","id":"CVE-2026-4177"},"packages":[],"prev":{"headline":"Aureus ERP Chatter Message content-text-entry.blade.php cross site scripting","id":"CVE-2026-4175"},"products":["perl"],"published":"2026-03-29","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2022-48522","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-12814","kev_date_added":null,"published":"2017-09-27"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2015-8608","kev_date_added":null,"published":"2017-02-07"},{"cvss_score":9.1,"headline":"Integer overflow in perl:perl","id":"CVE-2026-13221","kev_date_added":null,"published":"2026-07-13"},{"cvss_score":9.1,"headline":"Memory corruption in n/a","id":"CVE-2017-12883","kev_date_added":null,"published":"2017-09-19"},{"cvss_score":8.4,"headline":"Integer overflow in perl:perl","id":"CVE-2026-57432","kev_date_added":null,"published":"2026-07-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-30","vendors":["SHAY"]},"summary":"Perl includes a vulnerable vendored zlib in Compress::Raw::Zlib, allowing attackers to exploit underlying zlib flaws like code execution or DoS.","url":"https://insights.sbomify.com/CVE-2026-4176/"}