# CVE-2026-41838: Spring Framework Predictable Session ID in WebSocket Module

> Attackers can predict WebSocket session IDs to bypass authorization controls in applications using the Spring Framework WebSocket module.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** CLSA-2026-1783645402, CLSA-2026-1787559106, DEBIAN-CVE-2026-41838, ECHO-e4f7-3cd4-8c4e, GHSA-q723-847q-5g8g, UBUNTU-CVE-2026-41838

## What is CVE-2026-41838?

CVE-2026-41838 is a medium-severity vulnerability in Vmware Spring Framework, published on 9 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

IDs for WebSocket sessions in the spring-websocket module are not cryptographically unpredictable, which may be possible to exploit in combination with inadequate authorization rules.

Affected versions:
Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2026-41838?

8 open source packages ship an affected version, including org.springframework:spring-websocket. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-websocket` | Maven | All versions to 5.3.48 | None |
| `org.springframework:spring-websocket` | Maven | All versions to 5.3.48 | None |
| `org.springframework:spring-websocket` | Maven | From 6.1.0 to 6.1.27 | None |
| `org.springframework:spring-websocket` | Maven | From 6.1.0 to 6.1.27 | None |
| `org.springframework:spring-websocket` | Maven | From 6.2.0 | 6.2.19 |
| `org.springframework:spring-websocket` | Maven | From 6.2.0 | 6.2.19 |
| `org.springframework:spring-websocket` | Maven | From 7.0.0 | 7.0.8 |
| `org.springframework:spring-websocket` | Maven | From 7.0.0 | 7.0.8 |

Products: Vmware Spring Framework.

## How do I fix CVE-2026-41838?

Upgrade org.springframework:spring-websocket to a fixed version for your release line: 6.2.19 or 7.0.8.

## Is CVE-2026-41838 being exploited?

There is no known exploitation of CVE-2026-41838 in the wild and no public exploit code.

## Other vulnerabilities in Vmware Spring Framework

- [CVE-2026-47884](https://insights.sbomify.com/CVE-2026-47884/): Spring Framework Improper Path Limitation in XsltView (critical 9.8)
- [CVE-2026-47890](https://insights.sbomify.com/CVE-2026-47890/): Spring Framework Server Sent Event stream corruption while rendering fragments (critical 9.8)
- [CVE-2026-47891](https://insights.sbomify.com/CVE-2026-47891/): Spring Framework maxInMemorySize Bypassed in Jaxb2Decoder (critical 9.8)
- [CVE-2026-47892](https://insights.sbomify.com/CVE-2026-47892/): Spring Framework Header Predicate Bypass in WebFlux Functional Endpoints (critical 9.8)
- [CVE-2026-59313](https://insights.sbomify.com/CVE-2026-59313/): Server Sent Event stream corruption in Spring MVC functional web framework (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41838 and fix it if it is affected.

What it is: CVE-2026-41838 is a medium-severity vulnerability in Vmware Spring Framework, published on 9 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41838 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-websocket (Maven): affected all versions up to 5.3.48; no fix listed
- org.springframework:spring-websocket (Maven): affected all versions up to 5.3.48; no fix listed
- org.springframework:spring-websocket (Maven): affected from 6.1.0 up to 6.1.27; no fix listed
- org.springframework:spring-websocket (Maven): affected from 6.1.0 up to 6.1.27; no fix listed
- org.springframework:spring-websocket (Maven): affected from 6.2.0; fixed in 6.2.19
- org.springframework:spring-websocket (Maven): affected from 6.2.0; fixed in 6.2.19
- org.springframework:spring-websocket (Maven): affected from 7.0.0; fixed in 7.0.8
- org.springframework:spring-websocket (Maven): affected from 7.0.0; fixed in 7.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41838/ (Markdown: https://insights.sbomify.com/CVE-2026-41838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41838
- OSV: https://osv.dev/vulnerability/CVE-2026-41838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41838/
Summaries are generated and may contain mistakes; the official description above is the record.
