# CVE-2026-41843: Spring Framework Path Traversal via Versioned Static Resources in Spring MVC and WebFlux

> Attackers can read arbitrary files from the server via path traversal in static resource resolution, affecting Spring MVC and WebFlux applications.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** CLEANSTART-2026-ED39248, CLSA-2026-1788555932, CLSA-2026-1792114470, CLSA-2026-1792114646, CLSA-2026-1792114749, CLSA-2026-1792602382, CLSA-2026-1793101662, CLSA-2026-1793102691, CLSA-2026-1793106642, DEBIAN-CVE-2026-41843, ECHO-41ce-1fcb-d5f5, GHSA-72pg-x5f8-j25j, MINI-54v6-c45f-qvfc, MINI-83r6-3897-gwhf, MINI-9hrf-q6gg-58j4, MINI-hh86-6j62-hh9c, MINI-jj6f-hr8x-6r87, MINI-p7gg-6v67-6cj8, MINI-pxqx-m32j-5372, MINI-vj4x-cm3r-96p8, MINI-vwpr-p3j3-rhgq, MINI-xxgm-7m92-vh74, UBUNTU-CVE-2026-41843

## What is CVE-2026-41843?

CVE-2026-41843 is a medium-severity path traversal vulnerability in Vmware Spring Framework, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring MVC and WebFlux applications are vulnerable to Path Traversal attacks when resolving static resources.

Affected versions:
Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-41843?

16 open source packages ship an affected version, including org.springframework:spring-webflux and org.springframework:spring-webmvc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-webflux` | Maven | All versions to 5.3.39 | None |
| `org.springframework:spring-webflux` | Maven | All versions to 5.3.39 | None |
| `org.springframework:spring-webflux` | Maven | From 6.1.0 to 6.1.21 | None |
| `org.springframework:spring-webflux` | Maven | From 6.1.0 to 6.1.21 | None |
| `org.springframework:spring-webflux` | Maven | From 6.2.0 | 6.2.19 |
| `org.springframework:spring-webflux` | Maven | From 6.2.0 | 6.2.19 |
| `org.springframework:spring-webflux` | Maven | From 7.0.0 | 7.0.8 |
| `org.springframework:spring-webflux` | Maven | From 7.0.0 | 7.0.8 |
| `org.springframework:spring-webmvc` | Maven | All versions to 5.3.39 | None |
| `org.springframework:spring-webmvc` | Maven | All versions to 5.3.39 | None |
| `org.springframework:spring-webmvc` | Maven | From 6.1.0 to 6.1.21 | None |
| `org.springframework:spring-webmvc` | Maven | From 6.1.0 to 6.1.21 | None |
| `org.springframework:spring-webmvc` | Maven | From 6.2.0 | 6.2.19 |
| `org.springframework:spring-webmvc` | Maven | From 6.2.0 | 6.2.19 |
| `org.springframework:spring-webmvc` | Maven | From 7.0.0 | 7.0.8 |
| `org.springframework:spring-webmvc` | Maven | From 7.0.0 | 7.0.8 |

Products: Vmware Spring Framework.

## How do I fix CVE-2026-41843?

Upgrade org.springframework:spring-webflux to a fixed version for your release line: 6.2.19 or 7.0.8.

## Is CVE-2026-41843 being exploited?

There is no known exploitation of CVE-2026-41843 in the wild and no public exploit code.

## Other vulnerabilities in Vmware Spring Framework

- [CVE-2026-47884](https://insights.sbomify.com/CVE-2026-47884/): Spring Framework Improper Path Limitation in XsltView (critical 9.8)
- [CVE-2026-47890](https://insights.sbomify.com/CVE-2026-47890/): Spring Framework Server Sent Event stream corruption while rendering fragments (critical 9.8)
- [CVE-2026-47891](https://insights.sbomify.com/CVE-2026-47891/): Spring Framework maxInMemorySize Bypassed in Jaxb2Decoder (critical 9.8)
- [CVE-2026-47892](https://insights.sbomify.com/CVE-2026-47892/): Spring Framework Header Predicate Bypass in WebFlux Functional Endpoints (critical 9.8)
- [CVE-2026-59313](https://insights.sbomify.com/CVE-2026-59313/): Server Sent Event stream corruption in Spring MVC functional web framework (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41843 and fix it if it is affected.

What it is: CVE-2026-41843 is a medium-severity path traversal vulnerability in Vmware Spring Framework, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41843 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-webflux (Maven): affected all versions up to 5.3.39; no fix listed
- org.springframework:spring-webflux (Maven): affected all versions up to 5.3.39; no fix listed
- org.springframework:spring-webflux (Maven): affected from 6.1.0 up to 6.1.21; no fix listed
- org.springframework:spring-webflux (Maven): affected from 6.1.0 up to 6.1.21; no fix listed
- org.springframework:spring-webflux (Maven): affected from 6.2.0; fixed in 6.2.19
- org.springframework:spring-webflux (Maven): affected from 6.2.0; fixed in 6.2.19
- org.springframework:spring-webflux (Maven): affected from 7.0.0; fixed in 7.0.8
- org.springframework:spring-webflux (Maven): affected from 7.0.0; fixed in 7.0.8
- org.springframework:spring-webmvc (Maven): affected all versions up to 5.3.39; no fix listed
- org.springframework:spring-webmvc (Maven): affected all versions up to 5.3.39; no fix listed
- org.springframework:spring-webmvc (Maven): affected from 6.1.0 up to 6.1.21; no fix listed
- org.springframework:spring-webmvc (Maven): affected from 6.1.0 up to 6.1.21; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41843/ (Markdown: https://insights.sbomify.com/CVE-2026-41843/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41843
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41843
- OSV: https://osv.dev/vulnerability/CVE-2026-41843

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41843/
Summaries are generated and may contain mistakes; the official description above is the record.
