# CVE-2026-41846: Spring Framework Cross-site Scripting via JSP Form Tags

> Attackers can inject arbitrary HTML or JavaScript via JSP form tag attributes in Spring MVC applications, leading to cross-site scripting.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** CLEANSTART-2026-MG54008, CLSA-2026-1787649292, CLSA-2026-1790081501, CLSA-2026-1790081906, DEBIAN-CVE-2026-41846, ECHO-b5c1-467a-a853, GHSA-957g-f97v-vppc, MINI-329w-x9x3-3pv9, MINI-5gq8-48wx-pjxc, MINI-7rjp-p8g7-6pp5, MINI-95f2-4cpx-6fq5, MINI-h4hr-phxj-3j64, MINI-j3v3-cg83-q9jq, MINI-pg6f-pqp3-32c3, MINI-q87h-7jgf-8qhg, MINI-rqj2-hfcr-hgxg, MINI-vv8w-mf65-q8r7, ROOT-APP-MAVEN-CVE-2026-41846, UBUNTU-CVE-2026-41846

## What is CVE-2026-41846?

CVE-2026-41846 is a medium-severity cross-site scripting vulnerability in Vmware Spring Framework, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Spring MVC applications which accept user-supplied values in the cssClass, cssErrorClass, or cssStyle attributes of JSP form tags allow arbitrary HTML/JavaScript code injection, potentially resulting in a cross-site scripting (XSS) vulnerability.

Affected versions:
Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-41846?

8 open source packages ship an affected version, including org.springframework:spring-webmvc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-webmvc` | Maven | All versions to 5.3.39 | None |
| `org.springframework:spring-webmvc` | Maven | All versions to 5.3.39 | None |
| `org.springframework:spring-webmvc` | Maven | From 6.1.0 to 6.1.21 | None |
| `org.springframework:spring-webmvc` | Maven | From 6.1.0 to 6.1.21 | None |
| `org.springframework:spring-webmvc` | Maven | From 6.2.0 | 6.2.19 |
| `org.springframework:spring-webmvc` | Maven | From 6.2.0 | 6.2.19 |
| `org.springframework:spring-webmvc` | Maven | From 7.0.0 | 7.0.8 |
| `org.springframework:spring-webmvc` | Maven | From 7.0.0 | 7.0.8 |

Products: Vmware Spring Framework.

## How do I fix CVE-2026-41846?

Upgrade org.springframework:spring-webmvc to a fixed version for your release line: 6.2.19 or 7.0.8.

## Is CVE-2026-41846 being exploited?

There is no known exploitation of CVE-2026-41846 in the wild and no public exploit code.

## Other vulnerabilities in Vmware Spring Framework

- [CVE-2026-47884](https://insights.sbomify.com/CVE-2026-47884/): Spring Framework Improper Path Limitation in XsltView (critical 9.8)
- [CVE-2026-47890](https://insights.sbomify.com/CVE-2026-47890/): Spring Framework Server Sent Event stream corruption while rendering fragments (critical 9.8)
- [CVE-2026-47891](https://insights.sbomify.com/CVE-2026-47891/): Spring Framework maxInMemorySize Bypassed in Jaxb2Decoder (critical 9.8)
- [CVE-2026-47892](https://insights.sbomify.com/CVE-2026-47892/): Spring Framework Header Predicate Bypass in WebFlux Functional Endpoints (critical 9.8)
- [CVE-2026-59313](https://insights.sbomify.com/CVE-2026-59313/): Server Sent Event stream corruption in Spring MVC functional web framework (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41846 and fix it if it is affected.

What it is: CVE-2026-41846 is a medium-severity cross-site scripting vulnerability in Vmware Spring Framework, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41846 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-webmvc (Maven): affected all versions up to 5.3.39; no fix listed
- org.springframework:spring-webmvc (Maven): affected all versions up to 5.3.39; no fix listed
- org.springframework:spring-webmvc (Maven): affected from 6.1.0 up to 6.1.21; no fix listed
- org.springframework:spring-webmvc (Maven): affected from 6.1.0 up to 6.1.21; no fix listed
- org.springframework:spring-webmvc (Maven): affected from 6.2.0; fixed in 6.2.19
- org.springframework:spring-webmvc (Maven): affected from 6.2.0; fixed in 6.2.19
- org.springframework:spring-webmvc (Maven): affected from 7.0.0; fixed in 7.0.8
- org.springframework:spring-webmvc (Maven): affected from 7.0.0; fixed in 7.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41846/ (Markdown: https://insights.sbomify.com/CVE-2026-41846/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41846
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41846
- OSV: https://osv.dev/vulnerability/CVE-2026-41846

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41846/
Summaries are generated and may contain mistakes; the official description above is the record.
