CVE-2026-41850 Spring Framework Algorithmic Denial of Service via SpEL Expressions
Attackers can cause denial of service by submitting crafted SpEL expressions to applications that evaluate user input.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41850?
CVE-2026-41850 is a high-severity denial of service vulnerability in Vmware Spring Framework, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Applications that evaluate user-supplied Spring Expression Language (SpEL) expressions are vulnerable to an Algorithmic Denial of Service (DoS). By providing a specially crafted expression, an attacker can trigger excessive resource consumption during evaluation, leading to application degradation or unavailability.
Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.
Weakness: CWE-407
Which versions are affected by CVE-2026-41850?
8 open source packages ship an affected version, including org.springframework:spring-expression. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework:spring-expression Maven | All versions to 5.3.39 | None |
org.springframework:spring-expression Maven | All versions to 5.3.39 | None |
org.springframework:spring-expression Maven | From 6.1.0 to 6.1.21 | None |
org.springframework:spring-expression Maven | From 6.1.0 to 6.1.21 | None |
org.springframework:spring-expression Maven | From 6.2.0 | 6.2.19 |
org.springframework:spring-expression Maven | From 6.2.0 | 6.2.19 |
2 more packages
org.springframework:spring-expression Maven | From 7.0.0 | 7.0.8 |
org.springframework:spring-expression Maven | From 7.0.0 | 7.0.8 |
Products include Vmware Spring Framework.
How do I fix CVE-2026-41850?
Upgrade org.springframework:spring-expression to a fixed version for your release line: 6.2.19 or 7.0.8.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-41850 being exploited?
There is no known exploitation of CVE-2026-41850 in the wild and no public exploit code.
Other vulnerabilities in Vmware Spring Framework
- CVE-2026-47884 Spring Framework Improper Path Limitation in XsltView
- CVE-2026-47890 Spring Framework Server Sent Event stream corruption while rendering fragments
- CVE-2026-47891 Spring Framework maxInMemorySize Bypassed in Jaxb2Decoder
- CVE-2026-47892 Spring Framework Header Predicate Bypass in WebFlux Functional Endpoints
- CVE-2026-59313 Server Sent Event stream corruption in Spring MVC functional web framework
Sources
Also known as CLEANSTART-2026-CX77611, CLEANSTART-2026-IR60609, CLEANSTART-2026-TC92971, CLSA-2026-1793100043, CLSA-2026-1793103858, CLSA-2026-1793107481 and 26 more.