# CVE-2026-41856: Spring GraphQL Annotation Detection Vulnerability

> Attackers can bypass authorization checks in Spring GraphQL applications if security annotations are placed on inherited methods, potentially accessing unauthorized data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 30 Jun 2026
- **Also known as:** CLSA-2026-1789149911, CLSA-2026-1789369685, GHSA-phxq-526m-79px, ROOT-APP-MAVEN-CVE-2026-41856

## What is CVE-2026-41856?

CVE-2026-41856 is a high-severity missing authorization vulnerability in Spring for GraphQL, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Spring GraphQL annotation detection mechanism for @Controller data fetchers may not correctly resolve annotations on methods within type hierarchies. This can be an issue if such annotations are used for authorization decisions. When all conditions are met, security annotations can be ignored at runtime.

Affected versions:
Spring for GraphQL 2.0.0 through 2.0.3; 1.4.0 through 1.4.5; 1.3.0 through 1.3.8; 1.0.0 through 1.0.6.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-41856?

8 open source packages ship an affected version, including org.springframework.graphql:spring-graphql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.graphql:spring-graphql` | Maven | From 1.0.0 to 1.0.6 | None |
| `org.springframework.graphql:spring-graphql` | Maven | From 1.0.0 to 1.0.6 | None |
| `org.springframework.graphql:spring-graphql` | Maven | From 1.3.0 to 1.3.8 | None |
| `org.springframework.graphql:spring-graphql` | Maven | From 1.3.0 to 1.3.8 | None |
| `org.springframework.graphql:spring-graphql` | Maven | From 1.4.0 | 1.4.6 |
| `org.springframework.graphql:spring-graphql` | Maven | From 1.4.0 | 1.4.6 |
| `org.springframework.graphql:spring-graphql` | Maven | From 2.0.0 | 2.0.4 |
| `org.springframework.graphql:spring-graphql` | Maven | From 2.0.0 | 2.0.4 |

Products: Vmware Spring for Graphql.

## How do I fix CVE-2026-41856?

Upgrade org.springframework.graphql:spring-graphql to a fixed version for your release line: 1.4.6 or 2.0.4.

## Is CVE-2026-41856 being exploited?

There is no known exploitation of CVE-2026-41856 in the wild and no public exploit code.

## Other vulnerabilities in Spring for GraphQL

- [CVE-2026-59285](https://insights.sbomify.com/CVE-2026-59285/): Spring for GraphQL Unsafe Deserialization in pagination support (high 8.1)
- [CVE-2026-59286](https://insights.sbomify.com/CVE-2026-59286/): Spring for GraphQL loads Untrusted Resources in GraphiQL support (high 8.1)
- [CVE-2026-41699](https://insights.sbomify.com/CVE-2026-41699/): Unsafe Deserialization in Spring GraphQL (high 8.1)
- [CVE-2026-41700](https://insights.sbomify.com/CVE-2026-41700/): Cross-Site WebSocket Hijacking in Spring for GraphQL (high 8.1)
- [CVE-2026-59288](https://insights.sbomify.com/CVE-2026-59288/): Spring for GraphQL Information Exposure in GraphiQL support (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41856 and fix it if it is affected.

What it is: CVE-2026-41856 is a high-severity missing authorization vulnerability in Spring for GraphQL, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41856 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.graphql:spring-graphql (Maven): affected from 1.0.0 up to 1.0.6; no fix listed
- org.springframework.graphql:spring-graphql (Maven): affected from 1.0.0 up to 1.0.6; no fix listed
- org.springframework.graphql:spring-graphql (Maven): affected from 1.3.0 up to 1.3.8; no fix listed
- org.springframework.graphql:spring-graphql (Maven): affected from 1.3.0 up to 1.3.8; no fix listed
- org.springframework.graphql:spring-graphql (Maven): affected from 1.4.0; fixed in 1.4.6
- org.springframework.graphql:spring-graphql (Maven): affected from 1.4.0; fixed in 1.4.6
- org.springframework.graphql:spring-graphql (Maven): affected from 2.0.0; fixed in 2.0.4
- org.springframework.graphql:spring-graphql (Maven): affected from 2.0.0; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41856/ (Markdown: https://insights.sbomify.com/CVE-2026-41856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41856
- OSV: https://osv.dev/vulnerability/CVE-2026-41856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41856/
Summaries are generated and may contain mistakes; the official description above is the record.
