# CVE-2026-41860: Weak cryptography in BOSH

> A local attacker can intercept traffic and steal credentials because BOSH hard-codes SSL verification to none, allowing MITM attacks against the director or UAA.

- **Severity:** High 7.1 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Jun 2026
- **Updated:** 4 Jun 2026
- **Also known as:** GHSA-fqm2-p6px-f54c

## What is CVE-2026-41860?

CVE-2026-41860 is a high-severity vulnerability in Cloud Foundry Foundation BOSH, published on 4 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

CWE-326 in BOSH allows a local attacker to steal Basic-auth credentials or redirect UAA token requests via MITM. HttpRequestHelper#create_async_endpoint and #send_http_get_request_synchronous hard-code OpenSSL::SSL::VERIFY_NONE, enabling an attacker to intercept traffic between bosh-monitor and the BOSH director or UAA and steal credentials.

Affected versions:
- BOSH: all versions prior to v282.1.9 (inclusive); fixed in v282.1.9 or later

Weakness: CWE-326 (Inadequate Encryption Strength)

## Which versions are affected by CVE-2026-41860?


## How do I fix CVE-2026-41860?

No fix has been published for CVE-2026-41860 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-41860 being exploited?

There is no known exploitation of CVE-2026-41860 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41860 and fix it if it is affected.

What it is: CVE-2026-41860 is a high-severity vulnerability in Cloud Foundry Foundation BOSH, published on 4 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41860 in the wild and no public exploit code.

Affected product: Cloud Foundry Foundation BOSH. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41860/ (Markdown: https://insights.sbomify.com/CVE-2026-41860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41860
- OSV: https://osv.dev/vulnerability/CVE-2026-41860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41860/
Summaries are generated and may contain mistakes; the official description above is the record.
