CVE-2026-41869 Apache Nutch: Unauthenticated forced shutdown and job interruption in Nutch Server (Nutch REST API)

Critical 9.1 Published Updated

Unauthenticated attackers can force shutdown and interrupt jobs in Apache Nutch Server, causing denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-41869?

CVE-2026-41869 is a critical missing authorization vulnerability in Apache Nutch, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Missing Authorization, Improper Resource Shutdown and Job Interruption vulnerability in Apache Nutch Server (Nutch REST API).

This issue affects Apache Nutch: from 1.10 through 1.22.

Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

Weakness: CWE-862, CWE-404

Which versions are affected by CVE-2026-41869?

It affects 1 product.

Products include Apache Nutch.

How do I fix CVE-2026-41869?

No fix has been published for CVE-2026-41869 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-41869 being exploited?

There is no known exploitation of CVE-2026-41869 in the wild and no public exploit code.

Sources

Also known as GHSA-3fr3-2597-3735.

Is CVE-2026-41869 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free