CVE-2026-41870 Apache Nutch: Unauthenticated remote code execution (RCE) via JEXL injection in Nutch Server (Nutch REST API)

High 8.8 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2026-41870?

CVE-2026-41870 is a high-severity vulnerability in Apache Nutch, published on 9 Sep 2026.

Official description

Missing Authorization, Improper Control of Generation of Code ('Code Injection'), Improper Control of Dynamically-Managed Code Resources, Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Nutch Server (Nutch REST API).

This issue affects Apache Nutch: from 1.11 through 1.22.

Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

Weakness: CWE-94, CWE-913, CWE-862, CWE-470

Which versions are affected by CVE-2026-41870?

It affects 1 product.

Products include Apache Nutch.

How do I fix CVE-2026-41870?

No fix has been published for CVE-2026-41870 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-41870 being exploited?

There is no known exploitation of CVE-2026-41870 in the wild and no public exploit code.

Sources

Also known as GHSA-45q5-f4p5-jrqm.

Is CVE-2026-41870 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free