CVE-2026-41871 Apache Nutch: Unauthenticated reflection-based job execution in Nutch Server (Nutch REST API)

Critical 9.8 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2026-41871?

CVE-2026-41871 is a critical vulnerability in Apache Nutch, published on 9 Sep 2026.

Official description

Missing Authorization, Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Nutch Server (Nutch REST API).

This issue affects Apache Nutch: from 1.10 through 1.22.

Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

Weakness: CWE-862, CWE-470

Which versions are affected by CVE-2026-41871?

It affects 1 product.

Products include Apache Nutch.

How do I fix CVE-2026-41871?

No fix has been published for CVE-2026-41871 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-41871 being exploited?

There is no known exploitation of CVE-2026-41871 in the wild and no public exploit code.

Sources

Also known as GHSA-5w4f-vwv7-mj4c.

Is CVE-2026-41871 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free