# CVE-2026-41883: OmniFaces: EL injection via crafted resource name in wildcard CDN mapping

> Attacker can achieve remote code execution via EL injection in resource names when using wildcard CDN mapping in OmniFaces.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-vp6r-9m58-5xv8

## What is CVE-2026-41883?

CVE-2026-41883 is a high-severity code injection vulnerability in omnifaces, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OmniFaces is a utility library for Faces. Prior to versions 1.14.2, 2.7.32, 3.14.16, 4.7.5, and 5.2.3, there is a server-side EL injection leading to Remote Code Execution (RCE). This affects applications that use CDNResourceHandler with a wildcard CDN mapping (e.g. libraryName:*=https://cdn.example.com/*). An attacker can craft a resource request URL containing an EL expression in the resource name, which is evaluated server-side. This issue has been patched in versions 1.14.2, 2.7.32, 3.14.16, 4.7.5, and 5.2.3.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2026-41883?

10 open source packages ship an affected version, including org.omnifaces:omnifaces.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.omnifaces:omnifaces` | Maven | All versions | 1.14.2 |
| `org.omnifaces:omnifaces` | Maven | All versions | 1.14.2 |
| `org.omnifaces:omnifaces` | Maven | From 2.0-RC1 | 2.7.32 |
| `org.omnifaces:omnifaces` | Maven | From 2.0-RC1 | 2.7.32 |
| `org.omnifaces:omnifaces` | Maven | From 3.0-RC1 | 3.14.16 |
| `org.omnifaces:omnifaces` | Maven | From 3.0-RC1 | 3.14.16 |
| `org.omnifaces:omnifaces` | Maven | From 4.0-M1 | 4.7.5 |
| `org.omnifaces:omnifaces` | Maven | From 4.0-M1 | 4.7.5 |
| `org.omnifaces:omnifaces` | Maven | From 5.0-M1 | 5.2.3 |
| `org.omnifaces:omnifaces` | Maven | From 5.0-M1 | 5.2.3 |

## How do I fix CVE-2026-41883?

Upgrade org.omnifaces:omnifaces to a fixed version for your release line: 1.14.2, 2.7.32, 3.14.16 or 4.7.5.

## Is CVE-2026-41883 being exploited?

There is no known exploitation of CVE-2026-41883 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41883 and fix it if it is affected.

What it is: CVE-2026-41883 is a high-severity code injection vulnerability in omnifaces, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41883 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.omnifaces:omnifaces (Maven): affected all versions; fixed in 1.14.2
- org.omnifaces:omnifaces (Maven): affected all versions; fixed in 1.14.2
- org.omnifaces:omnifaces (Maven): affected from 2.0-RC1; fixed in 2.7.32
- org.omnifaces:omnifaces (Maven): affected from 2.0-RC1; fixed in 2.7.32
- org.omnifaces:omnifaces (Maven): affected from 3.0-RC1; fixed in 3.14.16
- org.omnifaces:omnifaces (Maven): affected from 3.0-RC1; fixed in 3.14.16
- org.omnifaces:omnifaces (Maven): affected from 4.0-M1; fixed in 4.7.5
- org.omnifaces:omnifaces (Maven): affected from 4.0-M1; fixed in 4.7.5
- org.omnifaces:omnifaces (Maven): affected from 5.0-M1; fixed in 5.2.3
- org.omnifaces:omnifaces (Maven): affected from 5.0-M1; fixed in 5.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41883/ (Markdown: https://insights.sbomify.com/CVE-2026-41883/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41883
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41883
- OSV: https://osv.dev/vulnerability/CVE-2026-41883

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41883/
Summaries are generated and may contain mistakes; the official description above is the record.
