{"answers":{"affected":"2 open source packages ship an affected version, including locize.","exploited":"There is no known exploitation of CVE-2026-41886 in the wild and no public exploit code.","fix":"Upgrade locize to 4.0.21 or later.","what":"CVE-2026-41886 is a high-severity cross-site scripting vulnerability in locize, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-41886 and fix it if it is affected.\n\nWhat it is: CVE-2026-41886 is a high-severity cross-site scripting vulnerability in locize, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-41886 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- locize (npm): affected all versions; fixed in 4.0.21\n- locize (npm): affected all versions; fixed in 4.0.21\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41886/ (Markdown: https://insights.sbomify.com/CVE-2026-41886/index.md)","id":"CVE-2026-41886","markdown":"https://insights.sbomify.com/CVE-2026-41886/index.md","name":"CVE-2026-41886","record":{"aliases":["GHSA-w937-fg2h-xhq2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"locize Client SDK","requires_auth":"none","summary":"Attackers can execute arbitrary scripts or hijack handlers in locize-enabled applications by sending crafted postMessages without origin validation.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-346","name":"Origin Validation Error"}],"description":"locize is a localization platform that connects code and i18n setup. Prior to version 4.0.21, the locize client SDK registers a window.addEventListener(\"message\", …) handler that dispatches to registered internal handlers (editKey, commitKey, commitKeys, isLocizeEnabled, requestInitialize, …) without validating event.origin. The pre-patch listener in src/api/postMessage.js gates dispatch on event.data.sender === \"i18next-editor-frame\" — that value sits inside the attacker-controlled message payload, not the browser-enforced origin. Any web page that could embed or be embedded by a locize-enabled host — an iframe on a third-party page, a window.open-ed victim, a parent frame reaching down — could send a crafted postMessage and trigger the internal handlers. This issue has been patched in version 4.0.21.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"locize Client SDK: Cross-origin DOM XSS \u0026 Handler Hijack Through Missing e.origin Validation in InContext Editor","id":"CVE-2026-41886","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)","id":"CVE-2026-41887"},"packages":[{"ecosystem":"npm","fixed":["4.0.21"],"introduced":["0"],"last_affected":[],"package":"locize","purl":null,"source":"GHSA-w937-fg2h-xhq2"},{"ecosystem":"npm","fixed":["4.0.21"],"introduced":["0"],"last_affected":[],"package":"locize","purl":"pkg:npm/locize","source":"GHSA-w937-fg2h-xhq2"}],"prev":{"headline":"Path traversal / URL injection via unsanitised lng/ns/projectId/version in i18next-locize-backend","id":"CVE-2026-41885"},"products":["locize"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-08","vendors":["locize"]},"summary":"Attackers can execute arbitrary scripts or hijack handlers in locize-enabled applications by sending crafted postMessages without origin validation.","url":"https://insights.sbomify.com/CVE-2026-41886/"}