CVE-2026-41887 Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)

Medium 4.9 Published Updated

An authenticated administrator can exploit path traversal in LESS theme settings to read arbitrary files or perform server-side request forgery.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41887?

CVE-2026-41887 is a medium-severity path traversal vulnerability in flarum framework, published on 8 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.

Weakness: CWE-918, CWE-22

Which versions are affected by CVE-2026-41887?

4 open source packages ship an affected version, including flarum/core.

PackageAffectedFixed in
flarum/core PackagistAll versions1.8.16
flarum/core PackagistAll versions1.8.16
flarum/core PackagistFrom 2.0.0-beta.12.0.0-rc.1
flarum/core PackagistFrom 2.0.0-beta.12.0.0-rc.1

How do I fix CVE-2026-41887?

Upgrade flarum/core to a fixed version for your release line: 1.8.16 or 2.0.0-rc.1.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-41887 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41887 exists.

Sources

Also known as GHSA-xjvc-pw2r-6878.

Is CVE-2026-41887 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free