{"answers":{"affected":"4 open source packages ship an affected version, including flarum/core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41887 exists.","fix":"Upgrade flarum/core to a fixed version for your release line: 1.8.16 or 2.0.0-rc.1.","what":"CVE-2026-41887 is a medium-severity path traversal vulnerability in flarum framework, published on 8 May 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41887 and fix it if it is affected.\n\nWhat it is: CVE-2026-41887 is a medium-severity path traversal vulnerability in flarum framework, published on 8 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41887 exists.\n\nAffected packages and fixed versions:\n- flarum/core (Packagist): affected all versions; fixed in 1.8.16\n- flarum/core (Packagist): affected all versions; fixed in 1.8.16\n- flarum/core (Packagist): affected from 2.0.0-beta.1; fixed in 2.0.0-rc.1\n- flarum/core (Packagist): affected from 2.0.0-beta.1; fixed in 2.0.0-rc.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41887/ (Markdown: https://insights.sbomify.com/CVE-2026-41887/index.md)","id":"CVE-2026-41887","markdown":"https://insights.sbomify.com/CVE-2026-41887/index.md","name":"CVE-2026-41887","record":{"aliases":["GHSA-xjvc-pw2r-6878"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","other"],"network_reachable":"yes","non_default_config":false,"product_category":"Flarum forum software","requires_auth":"high_privilege","summary":"An authenticated administrator can exploit path traversal in LESS theme settings to read arbitrary files or perform server-side request forgery.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '\u003cpath\u003e', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)","id":"CVE-2026-41887","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"Distribution: Tag deletion bypasses `storage.delete.enabled` configuration","id":"CVE-2026-41888"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.16"],"introduced":["0"],"last_affected":[],"package":"flarum/core","purl":null,"source":"GHSA-xjvc-pw2r-6878"},{"ecosystem":"Packagist","fixed":["1.8.16"],"introduced":["0"],"last_affected":[],"package":"flarum/core","purl":"pkg:composer/flarum/core","source":"GHSA-xjvc-pw2r-6878"},{"ecosystem":"Packagist","fixed":["2.0.0-rc.1"],"introduced":["2.0.0-beta.1"],"last_affected":[],"package":"flarum/core","purl":null,"source":"GHSA-xjvc-pw2r-6878"},{"ecosystem":"Packagist","fixed":["2.0.0-rc.1"],"introduced":["2.0.0-beta.1"],"last_affected":[],"package":"flarum/core","purl":"pkg:composer/flarum/core","source":"GHSA-xjvc-pw2r-6878"}],"prev":{"headline":"locize Client SDK: Cross-origin DOM XSS \u0026 Handler Hijack Through Missing e.origin Validation in InContext Editor","id":"CVE-2026-41886"},"products":["framework"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-08","vendors":["flarum"]},"summary":"An authenticated administrator can exploit path traversal in LESS theme settings to read arbitrary files or perform server-side request forgery.","url":"https://insights.sbomify.com/CVE-2026-41887/"}