# CVE-2026-41887: Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)

> An authenticated administrator can exploit path traversal in LESS theme settings to read arbitrary files or perform server-side request forgery.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-xjvc-pw2r-6878

## What is CVE-2026-41887?

CVE-2026-41887 is a medium-severity path traversal vulnerability in flarum framework, published on 8 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-41887?

4 open source packages ship an affected version, including flarum/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flarum/core` | Packagist | All versions | 1.8.16 |
| `flarum/core` | Packagist | All versions | 1.8.16 |
| `flarum/core` | Packagist | From 2.0.0-beta.1 | 2.0.0-rc.1 |
| `flarum/core` | Packagist | From 2.0.0-beta.1 | 2.0.0-rc.1 |

## How do I fix CVE-2026-41887?

Upgrade flarum/core to a fixed version for your release line: 1.8.16 or 2.0.0-rc.1.

## Is CVE-2026-41887 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41887 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41887 and fix it if it is affected.

What it is: CVE-2026-41887 is a medium-severity path traversal vulnerability in flarum framework, published on 8 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41887 exists.

Affected packages and fixed versions:
- flarum/core (Packagist): affected all versions; fixed in 1.8.16
- flarum/core (Packagist): affected all versions; fixed in 1.8.16
- flarum/core (Packagist): affected from 2.0.0-beta.1; fixed in 2.0.0-rc.1
- flarum/core (Packagist): affected from 2.0.0-beta.1; fixed in 2.0.0-rc.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41887/ (Markdown: https://insights.sbomify.com/CVE-2026-41887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41887
- OSV: https://osv.dev/vulnerability/CVE-2026-41887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41887/
Summaries are generated and may contain mistakes; the official description above is the record.
