# CVE-2026-41891: CI4MS: Deactivated User Session Bypass (active=0)

> Deactivated users can bypass authentication checks in CI4MS due to commented-out code, allowing unauthorized access to the system.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-5hfv-c864-qcq9

## What is CVE-2026-41891?

CVE-2026-41891 is a medium-severity authentication bypass vulnerability in ci4-cms-erp ci4ms, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. From version 0.26.0 to before version 0.31.8.0, the auth filter has the deactivated/banned user check commented out. This issue has been patched in version 0.31.8.0.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-41891?

2 open source packages ship an affected version, including ci4-cms-erp/ci4ms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ci4-cms-erp/ci4ms` | Packagist | From 0.26.0 | 0.31.8.0 |
| `ci4-cms-erp/ci4ms` | Packagist | From 0.26.0 | 0.31.8.0 |

## How do I fix CVE-2026-41891?

Upgrade ci4-cms-erp/ci4ms to 0.31.8.0 or later.

## Is CVE-2026-41891 being exploited?

There is no known exploitation of CVE-2026-41891 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41891 and fix it if it is affected.

What it is: CVE-2026-41891 is a medium-severity authentication bypass vulnerability in ci4-cms-erp ci4ms, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41891 in the wild and no public exploit code.

Affected packages and fixed versions:
- ci4-cms-erp/ci4ms (Packagist): affected from 0.26.0; fixed in 0.31.8.0
- ci4-cms-erp/ci4ms (Packagist): affected from 0.26.0; fixed in 0.31.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41891/ (Markdown: https://insights.sbomify.com/CVE-2026-41891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41891
- OSV: https://osv.dev/vulnerability/CVE-2026-41891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41891/
Summaries are generated and may contain mistakes; the official description above is the record.
