# CVE-2026-41893: Signal K Server's WebSocket Login Endpoint Lacks Rate Limiting (Credential Brute-Force)

> Attackers can bypass HTTP rate limits via WebSocket to brute-force credentials, potentially taking over accounts on Signal K Server.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-vmfm-ch9h-5c7g

## What is CVE-2026-41893?

CVE-2026-41893 is a high-severity vulnerability in signalk-server, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Signal K Server is a server application that runs on a central hub in a boat. Prior to version 2.25.0, the HTTP login endpoints (POST /login and POST /signalk/v1/auth/login) are protected by express-rate-limit (default: 100 attempts per 10-minute window, configurable via HTTP_RATE_LIMITS). The WebSocket login path — sending {login: {username, password}} messages over an established WebSocket connection — calls app.securityStrategy.login() directly without any rate limiting. An attacker can bypass HTTP rate limiting entirely by opening a WebSocket connection and attempting unlimited password guesses at the speed bcrypt allows (~20 attempts/sec with 10 salt rounds). This issue has been patched in version 2.25.0.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-41893?

2 open source packages ship an affected version, including signalk-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `signalk-server` | npm | All versions | 2.25.0 |
| `signalk-server` | npm | All versions | 2.25.0 |

Products: Signalk Signal K Server.

## How do I fix CVE-2026-41893?

Upgrade signalk-server to 2.25.0 or later.

## Is CVE-2026-41893 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41893 exists.

## Other vulnerabilities in signalk-server

- [CVE-2026-23515](https://insights.sbomify.com/CVE-2026-23515/): RCE - Command Injection in Signal K set-system-time plugin (critical 10.0)
- [CVE-2025-66398](https://insights.sbomify.com/CVE-2025-66398/): Signal K Server has Unauthenticated State Pollution leading to Remote Code Execution (RCE) (critical 9.7)
- [CVE-2026-33950](https://insights.sbomify.com/CVE-2026-33950/): signalk-server: Privilege Escalation by Admin Role Injection via /enableSecurity (critical 9.4)
- [CVE-2025-68620](https://insights.sbomify.com/CVE-2025-68620/): Signal K Server vulnerable to JWT Token Theft via WebSocket Enumeration and Unauthenticated Polling (critical 9.1)
- [CVE-2026-39320](https://insights.sbomify.com/CVE-2026-39320/): Signal K Server has an Unauthenticated Regular Expression Denial of Service (ReDoS) via WebSocket Subscription Paths (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41893 and fix it if it is affected.

What it is: CVE-2026-41893 is a high-severity vulnerability in signalk-server, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41893 exists.

Affected packages and fixed versions:
- signalk-server (npm): affected all versions; fixed in 2.25.0
- signalk-server (npm): affected all versions; fixed in 2.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41893/ (Markdown: https://insights.sbomify.com/CVE-2026-41893/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41893
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41893
- OSV: https://osv.dev/vulnerability/CVE-2026-41893

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41893/
Summaries are generated and may contain mistakes; the official description above is the record.
