# CVE-2026-41897: MantisBT: Reflected XSS in Rendering Dynamic Custom Textarea Field

> Attackers can inject arbitrary HTML via the filter_target parameter in MantisBT, potentially leading to session hijacking or malicious script execution.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 30 May 2026
- **Also known as:** GHSA-j7v9-f46r-2rp4

## What is CVE-2026-41897?

CVE-2026-41897 is a medium-severity cross-site scripting vulnerability in mantisbt, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. From 1.0.0 to 2.28.1, lack of validation of filter_target parameter on return_dynamic_filters.php (normally used as an AJAX in View Issues Page) allows an attacker to inject arbitrary HTML if the target is a TEXTAREA custom field. This vulnerability is fixed in 2.28.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-41897?

2 open source packages ship an affected version, including mantisbt/mantisbt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | From 1.0.0 | 2.28.2 |
| `mantisbt/mantisbt` | Packagist | From 1.0.0 | 2.28.2 |

## How do I fix CVE-2026-41897?

Upgrade mantisbt/mantisbt to 2.28.2 or later.

## Is CVE-2026-41897 being exploited?

There is no known exploitation of CVE-2026-41897 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41897 and fix it if it is affected.

What it is: CVE-2026-41897 is a medium-severity cross-site scripting vulnerability in mantisbt, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41897 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected from 1.0.0; fixed in 2.28.2
- mantisbt/mantisbt (Packagist): affected from 1.0.0; fixed in 2.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41897/ (Markdown: https://insights.sbomify.com/CVE-2026-41897/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41897
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41897
- OSV: https://osv.dev/vulnerability/CVE-2026-41897

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41897/
Summaries are generated and may contain mistakes; the official description above is the record.
