# CVE-2026-41898: rust-openssl: Unchecked callback length in PSK/cookie trampolines leaks adjacent memory to peer

> Attackers can trigger memory leaks or corruption in Rust applications using rust-openssl by exploiting unchecked callback lengths in PSK and cookie generation.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** AZL-84606, DEBIAN-CVE-2026-41898, GHSA-hppc-g8h3-xhp3, MINI-2cxv-gvqx-8whw, MINI-3xfr-hhf8-mgg3, MINI-48g7-r9w8-84xf, MINI-9m7q-6wg4-363f, MINI-cj9x-w323-jp2f, MINI-gc7c-4g3g-3hcv, MINI-jfh4-m2p8-pq58, MINI-vqcj-p7jf-8m62, UBUNTU-CVE-2026-41898

## What is CVE-2026-41898?

CVE-2026-41898 is a high-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rust-openssl provides OpenSSL bindings for the Rust programming language.  From 0.9.24 to before 0.10.78, the FFI trampolines behind SslContextBuilder::set_psk_client_callback, set_psk_server_callback, set_cookie_generate_cb, and set_stateless_cookie_generate_cb forwarded the user closure's returned usize directly to OpenSSL without checking it against the &mut [u8] that was handed to the closure. This can lead to buffer overflows and other unintended consequences. This vulnerability is fixed in 0.10.78.

Weakness: CWE-130 (Improper Handling of Length Parameter Inconsistency), CWE-126 (Buffer Over-read)

## Which versions are affected by CVE-2026-41898?

2 open source packages ship an affected version, including openssl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | crates.io | From 0.9.24 | 0.10.78 |
| `openssl` | crates.io | From 0.9.24 | 0.10.78 |

Products: Rust-Openssl Project Rust-Openssl.

## How do I fix CVE-2026-41898?

Upgrade openssl to 0.10.78 or later.

## Is CVE-2026-41898 being exploited?

There is no known exploitation of CVE-2026-41898 in the wild and no public exploit code.

## Other vulnerabilities in rust-openssl

- [CVE-2018-20997](https://insights.sbomify.com/CVE-2018-20997/): Use after free in openssl (critical 9.8)
- [CVE-2026-41681](https://insights.sbomify.com/CVE-2026-41681/): rust-openssl: MdCtxRef::digest_final() writes past caller buffer with no length check (high 8.1)
- [CVE-2016-10931](https://insights.sbomify.com/CVE-2016-10931/): Improper Certificate Validation in openssl (high 8.1)
- [CVE-2026-41676](https://insights.sbomify.com/CVE-2026-41676/): rust-openssl: Deriver::derive and PkeyCtxRef::derive can overflow short buffers on OpenSSL 1.1.1 (high 7.2)
- [CVE-2026-41678](https://insights.sbomify.com/CVE-2026-41678/): rust-openssl: Incorrect bounds assertion in aes key wrap (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41898 and fix it if it is affected.

What it is: CVE-2026-41898 is a high-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41898 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (crates.io): affected from 0.9.24; fixed in 0.10.78
- openssl (crates.io): affected from 0.9.24; fixed in 0.10.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41898/ (Markdown: https://insights.sbomify.com/CVE-2026-41898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41898
- OSV: https://osv.dev/vulnerability/CVE-2026-41898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41898/
Summaries are generated and may contain mistakes; the official description above is the record.
