# CVE-2026-41900: OpenLearnX has Critical Remote Code Execution Through Python Sandbox Escape via Code Execution Environment

> Attackers can escape the Python sandbox to execute arbitrary commands remotely on OpenLearnX deployments.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-8h25-q488-4hxw

## What is CVE-2026-41900?

CVE-2026-41900 is a high-severity code injection vulnerability in th30d4y OpenLearnX, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenLearnX is an open-source, decentralized learning and assessment platform. Prior to version 2.0.3, a remote code execution (RCE) vulnerability was identified in the OpenLearnX code execution environment, allowing sandbox escape and arbitrary command execution. This issue has been patched in version 2.0.3.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-693 (Protection Mechanism Failure), CWE-284 (Improper Access Control), CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2026-41900?

2 open source packages ship an affected version, including openlearnx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openlearnx` | npm | All versions | 2.0.3 |
| `openlearnx` | npm | All versions | 2.0.3 |

Products: Th30d4y Openlearnx.

## How do I fix CVE-2026-41900?

Upgrade openlearnx to 2.0.3 or later.

## Is CVE-2026-41900 being exploited?

There is no known exploitation of CVE-2026-41900 in the wild and no public exploit code.

Public exploit code:

- OpenLearnX Unauthenticated RCE (github_poc): https://github.com/Christbowel/CVE-2026-41900-POC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41900 and fix it if it is affected.

What it is: CVE-2026-41900 is a high-severity code injection vulnerability in th30d4y OpenLearnX, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41900 in the wild and no public exploit code.

Affected packages and fixed versions:
- openlearnx (npm): affected all versions; fixed in 2.0.3
- openlearnx (npm): affected all versions; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41900/ (Markdown: https://insights.sbomify.com/CVE-2026-41900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41900
- OSV: https://osv.dev/vulnerability/CVE-2026-41900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41900/
Summaries are generated and may contain mistakes; the official description above is the record.
