# CVE-2026-41903: Missing authorization in freescout

> A user with edit permissions can modify any other user's notification subscriptions, potentially suppressing security alerts for administrators.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-f489-qxv6-gvgg

## What is CVE-2026-41903?

CVE-2026-41903 is a medium-severity missing authorization vulnerability in freescout-help-desk freescout, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FreeScout is a free help desk and shared inbox built with PHP's Laravel framework. Prior to version 1.8.217, a user holding the PERM_EDIT_USERS permission (intended for general user-profile editing) can read and modify the notification subscriptions of any other user, including admins, by sending a single POST request. This is a sibling of CVE-2025-48472's notification authorization bypass — the prior fix did not cover this code path. A non-admin attacker can silently disable an admin's email/browser/mobile notifications, suppressing security alerts and conversation-assignment notices. This issue has been patched in version 1.8.217.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-41903?


## How do I fix CVE-2026-41903?

No fix has been published for CVE-2026-41903 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-41903 being exploited?

There is no known exploitation of CVE-2026-41903 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41903 and fix it if it is affected.

What it is: CVE-2026-41903 is a medium-severity missing authorization vulnerability in freescout-help-desk freescout, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41903 in the wild and no public exploit code.

Affected product: freescout-help-desk freescout. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41903/ (Markdown: https://insights.sbomify.com/CVE-2026-41903/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41903
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41903
- OSV: https://osv.dev/vulnerability/CVE-2026-41903

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41903/
Summaries are generated and may contain mistakes; the official description above is the record.
