# CVE-2026-41905: Server-side request forgery in freescout

> Attackers can exploit a redirect validation flaw in FreeScout to access internal network resources and cloud metadata endpoints.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-22wf-848c-c856

## What is CVE-2026-41905?

CVE-2026-41905 is a high-severity server-side request forgery vulnerability in freescout-help-desk freescout, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FreeScout is a free help desk and shared inbox built with PHP's Laravel framework. Prior to version 1.8.217, Helper::sanitizeRemoteUrl() in app/Misc/Helper.php follows HTTP redirects via curlGetLastRedirectedUrl() but then re-validates the original URL instead of the final redirect destination. An attacker who can supply any URL that passes the initial host check can redirect FreeScout to internal HTTP services (cloud metadata, internal APIs, RFC1918 ranges) that would normally be blocked. This issue has been patched in version 1.8.217.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-41905?


## How do I fix CVE-2026-41905?

No fix has been published for CVE-2026-41905 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-41905 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41905 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41905 and fix it if it is affected.

What it is: CVE-2026-41905 is a high-severity server-side request forgery vulnerability in freescout-help-desk freescout, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41905 exists.

Affected product: freescout-help-desk freescout. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41905/ (Markdown: https://insights.sbomify.com/CVE-2026-41905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41905
- OSV: https://osv.dev/vulnerability/CVE-2026-41905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41905/
Summaries are generated and may contain mistakes; the official description above is the record.
