# CVE-2026-41906: FreeScout: Conversation Change-Customer Cross-Mailbox Authorization Bypass

> A low-privileged agent can bypass authorization checks to bind conversations to customers in other mailboxes, modifying data across scopes.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-p6hg-2cwg-rrx9

## What is CVE-2026-41906?

CVE-2026-41906 is a high-severity missing authorization vulnerability in freescout-help-desk freescout, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FreeScout is a free help desk and shared inbox built with PHP's Laravel framework. Prior to version 1.8.214, the Change Customer modal correctly hides out-of-scope customers through the mailbox-filtered search endpoint, but the backend conversation_change_customer action accepts any supplied customer_email. A low-privileged agent can forge a request and bind a visible conversation to a hidden customer in another mailbox. This issue has been patched in version 1.8.214.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-41906?


## How do I fix CVE-2026-41906?

No fix has been published for CVE-2026-41906 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-41906 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41906 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41906 and fix it if it is affected.

What it is: CVE-2026-41906 is a high-severity missing authorization vulnerability in freescout-help-desk freescout, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41906 exists.

Affected product: freescout-help-desk freescout. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41906/ (Markdown: https://insights.sbomify.com/CVE-2026-41906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41906
- OSV: https://osv.dev/vulnerability/CVE-2026-41906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41906/
Summaries are generated and may contain mistakes; the official description above is the record.
