CVE-2026-41914 OpenClaw < 2026.4.8 - Server-Side Request Forgery in QQ Bot Media Fetch Paths
Attackers can exploit unprotected media fetch endpoints in OpenClaw to access internal resources and bypass allowlist policies.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41914?
CVE-2026-41914 is a medium-severity server-side request forgery vulnerability in Openclaw Openclaw, published on 28 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw before 2026.4.8 contains a server-side request forgery vulnerability in QQ Bot media download paths that bypass SSRF protection. Attackers can exploit unprotected media fetch endpoints to access internal resources and bypass allowlist policies.
Weakness: CWE-918
Which versions are affected by CVE-2026-41914?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.4.8 |
openclaw npm | All versions | 2026.4.8 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-41914?
Upgrade openclaw to 2026.4.8 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-41914 being exploited?
There is no known exploitation of CVE-2026-41914 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-3fv3-6p2v-gxwj, MINI-4whg-4gg9-j6g9.