CVE-2026-42027 Apache OpenNLP: Arbitrary Class Instantiation via Model Manifest in ExtensionLoader
Attackers can trigger arbitrary class static initializers via crafted model archives, potentially leading to code execution or security bypasses.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42027?
CVE-2026-42027 is a critical unsafe deserialization vulnerability in Apache OpenNLP, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Arbitrary Class Instantiation via Model Manifest in Apache OpenNLP ExtensionLoader
Versions Affected: before 1.9.5, before 2.5.9, before 3.0.0-M3
Description:
The ExtensionLoader.instantiateExtension(Class, String) method loads a class by its fully-qualified name via Class.forName() and invokes its no-arg constructor, with the class name sourced from the manifest.properties entry of a model archive. The existing isAssignableFrom check correctly rejects classes that are not subtypes of the expected extension interface (BaseToolFactory for factory=, ArtifactSerializer for serializer-class-*), but the check runs after Class.forName() has already loaded and initialized the named class.
Class.forName() with default initialization semantics executes the target class's static initializer before returning, so an attacker who can supply a crafted model archive can cause the static initializer of any class on the classpath to run during model loading, regardless of whether that class passes the subsequent type check.
Exploitation requires a class with attacker-useful side effects in its static initializer (for example, JNDI lookup, outbound network I/O, or filesystem access) to be present on the classpath, so this is not a drop-in remote code execution; however, the attack surface grows as third-party model distribution becomes more common (community model repositories, Hugging Face-style sharing), where users routinely load model files from origins they do not control. A secondary, narrower vector affects deployments that ship legitimate BaseToolFactory or ArtifactSerializer subclasses with side-effecting no-arg constructors: a malicious manifest can name such a class and force its constructor to run during model load.
Mitigation:
* 2.x users should upgrade to 2.5.9. * 3.x users should upgrade to 3.0.0-M3.
Note: The fix introduces a package-prefix allowlist that is consulted before Class.forName() is invoked, so the static initializer of a disallowed class is never executed. Classes under the opennlp. prefix remain permitted by default. Deployments that load models referencing factories or serializers outside opennlp.* must opt those packages in, either programmatically via ExtensionLoader.registerAllowedPackage(String) before the first model load, or by setting the OPENNLP_EXT_ALLOWED_PACKAGES system property to a comma-separated list of allowed package prefixes.
Users who cannot upgrade immediately should ensure that all model files are sourced from trusted origins and should audit their classpath for classes with side-effecting static initializers or constructors, particularly any that perform JNDI lookups, network requests, or filesystem operations during class initialization.
Which versions are affected by CVE-2026-42027?
6 open source packages ship an affected version, including org.apache.opennlp:opennlp-tools. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.opennlp:opennlp-tools Maven | All versions | 1.9.5 |
org.apache.opennlp:opennlp-tools Maven | All versions | 1.9.5 |
org.apache.opennlp:opennlp-tools Maven | From 2.0.0 | 2.5.9 |
org.apache.opennlp:opennlp-tools Maven | From 2.0.0 | 2.5.9 |
org.apache.opennlp:opennlp-tools Maven | From 3.0.0-M1 | 3.0.0-M3 |
org.apache.opennlp:opennlp-tools Maven | From 3.0.0-M1 | 3.0.0-M3 |
Products include Apache Opennlp.
How do I fix CVE-2026-42027?
Upgrade org.apache.opennlp:opennlp-tools to a fixed version for your release line: 1.9.5, 2.5.9 or 3.0.0-M3.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-42027 being exploited?
There is no known exploitation of CVE-2026-42027 in the wild and no public exploit code.
Other vulnerabilities in Apache OpenNLP
- CVE-2026-82617 Apache OpenNLP, Apache OpenNLP: ReDoS / stack exhaustion in RegexNameFinderFactory built-in EMAIL and URL patterns
- CVE-2017-12620 Improper Restriction of XML External Entity Reference in Apache OpenNLP
- CVE-2026-40682 Apache OpenNLP: XXE via Dictionary Parsing in DictionaryEntryPersistor
- CVE-2026-67211 Apache OpenNLP: OOM DoS via Unbounded Array Allocation in SymSpellModelSerializer
- CVE-2026-42440 Apache OpenNLP: OOM DoS via Unbounded Array Allocation in AbstractModelReader
Sources
Also known as DEBIAN-CVE-2026-42027, GHSA-cx4m-2p55-rw7j, UBUNTU-CVE-2026-42027.