# CVE-2026-42034: Axios: HTTP adapter streamed uploads bypass maxBodyLength when maxRedirects: 0

> Attackers can bypass body size limits in Axios when redirects are disabled, potentially causing resource exhaustion via oversized streamed uploads.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** CLEANSTART-2026-HP56001, CLEANSTART-2026-QA07785, DEBIAN-CVE-2026-42034, ECHO-b685-1bdb-e770, GHSA-5c9x-8gcm-mpgx, MINI-2229-pjx5-5fcf, MINI-22rj-r42g-9p7r, MINI-3cm3-x6p8-hjr7, MINI-3q64-x4rj-9pr8, MINI-694w-jr27-6g9w, MINI-6qcj-7g2v-93x7, MINI-74x8-3wh7-2cj2, MINI-7c7h-5xv6-452p, MINI-7f5p-22c5-x7cr, MINI-7pxj-592m-q8v9, MINI-7wmm-8p66-vhh2, MINI-fj29-3v46-2h62, MINI-fvgr-9g4g-gp4c, MINI-g3xr-mwww-hgm2, MINI-ghm7-cwg5-6mx6, MINI-pj4h-3669-w8gv, MINI-q483-fjxf-fgwx, MINI-w68v-w3f8-6w3r, MINI-x3vv-37gg-cxhx, ROOT-APP-NPM-CVE-2026-42034, UBUNTU-CVE-2026-42034

## What is CVE-2026-42034?

CVE-2026-42034 is a medium-severity denial of service vulnerability in axios, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise based HTTP client for the browser and Node.js. Prior to 1.15.1 and 0.31.1, for stream request bodies, maxBodyLength is bypassed when maxRedirects is set to 0 (native http/https transport path). Oversized streamed uploads are sent fully even when the caller sets strict body limits. This vulnerability is fixed in 1.15.1 and 0.31.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-42034?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.31.1 |
| `axios` | npm | All versions | 0.31.1 |
| `axios` | npm | From 1.0.0 | 1.15.1 |
| `axios` | npm | From 1.0.0 | 1.15.1 |

Products: Axios Axios.

## How do I fix CVE-2026-42034?

Upgrade axios to a fixed version for your release line: 0.31.1 or 1.15.1.

## Is CVE-2026-42034 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42034 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42034 and fix it if it is affected.

What it is: CVE-2026-42034 is a medium-severity denial of service vulnerability in axios, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42034 exists.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.31.1
- axios (npm): affected all versions; fixed in 0.31.1
- axios (npm): affected from 1.0.0; fixed in 1.15.1
- axios (npm): affected from 1.0.0; fixed in 1.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42034/ (Markdown: https://insights.sbomify.com/CVE-2026-42034/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42034
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42034
- OSV: https://osv.dev/vulnerability/CVE-2026-42034

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42034/
Summaries are generated and may contain mistakes; the official description above is the record.
