# CVE-2026-42036: Axios: HTTP adapter streamed responses bypass maxContentLength

> Attackers can cause resource exhaustion by bypassing response size limits when streaming responses, requiring developers to upgrade the library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** CLEANSTART-2026-CF31856, CLEANSTART-2026-DC50451, DEBIAN-CVE-2026-42036, ECHO-675c-1a43-6f9d, GHSA-vf2m-468p-8v99, MINI-2h6g-6r6h-vr46, MINI-2hwr-869m-472h, MINI-6p74-r423-2hg6, MINI-7875-8gf2-p75h, MINI-8m58-mhc6-x5f9, MINI-8r9c-qvj8-494g, MINI-8rc2-99hf-5fxx, MINI-94j6-22mw-26vx, MINI-ccgw-xx33-pmxv, MINI-cmfr-r4gf-wj5c, MINI-cvhp-8mgq-xpg2, MINI-fr97-v89m-6cff, MINI-h2j7-jrpp-5h8c, MINI-px37-5f4c-6jqg, MINI-q2f5-vqq4-w4mq, MINI-r947-f84j-h9rg, MINI-vfh5-3cjw-w3rp, MINI-wrgp-pv73-7q7f, MINI-xw9w-h925-435c, ROOT-APP-NPM-CVE-2026-42036, UBUNTU-CVE-2026-42036

## What is CVE-2026-42036?

CVE-2026-42036 is a medium-severity denial of service vulnerability in axios, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise based HTTP client for the browser and Node.js. Prior to 1.15.1 and 0.31.1, when responseType: 'stream' is used, Axios returns the response stream without enforcing maxContentLength. This bypasses configured response-size limits and allows unbounded downstream consumption. This vulnerability is fixed in 1.15.1 and 0.31.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-42036?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.31.1 |
| `axios` | npm | All versions | 0.31.1 |
| `axios` | npm | From 1.0.0 | 1.15.1 |
| `axios` | npm | From 1.0.0 | 1.15.1 |

Products: Axios Axios.

## How do I fix CVE-2026-42036?

Upgrade axios to a fixed version for your release line: 0.31.1 or 1.15.1.

## Is CVE-2026-42036 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42036 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42036 and fix it if it is affected.

What it is: CVE-2026-42036 is a medium-severity denial of service vulnerability in axios, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42036 exists.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.31.1
- axios (npm): affected all versions; fixed in 0.31.1
- axios (npm): affected from 1.0.0; fixed in 1.15.1
- axios (npm): affected from 1.0.0; fixed in 1.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42036/ (Markdown: https://insights.sbomify.com/CVE-2026-42036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42036
- OSV: https://osv.dev/vulnerability/CVE-2026-42036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42036/
Summaries are generated and may contain mistakes; the official description above is the record.
