# CVE-2026-42037: Axios: CRLF Injection in multipart/form-data body via unsanitized blob.type in formDataToStream

> Attackers can inject arbitrary MIME headers into multipart requests via unsanitized blob types, bypassing Node.js protections and altering request structure.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 27 Apr 2026
- **Also known as:** CLEANSTART-2026-GJ80180, CLEANSTART-2026-HP63393, DEBIAN-CVE-2026-42037, ECHO-96d5-9fbe-5e29, GHSA-445q-vr5w-6q77, MINI-3fmx-xvwg-j8gp, MINI-4xmr-j8fx-vhxj, MINI-5rch-hgmm-3vx9, MINI-83gj-gp9p-275w, MINI-84cq-c477-753f, MINI-84j9-8657-xcjg, MINI-878q-wqmm-w4p9, MINI-932f-v2fg-jv9c, MINI-9m59-6pv2-w5f9, MINI-f42w-wjx7-8vr5, MINI-gfgf-hxcj-vphw, MINI-j2q7-f9h2-fq39, MINI-pwrq-gm2c-r9pv, MINI-qfjv-vhr3-fphg, MINI-rgxj-c7j7-hghr, MINI-vhx9-hxp2-jc69, MINI-w7r8-w453-fpxr, MINI-x6qj-j56h-m6fw, MINI-xvhp-2grc-p35c, ROOT-APP-NPM-CVE-2026-42037, UBUNTU-CVE-2026-42037

## What is CVE-2026-42037?

CVE-2026-42037 is a medium-severity vulnerability in axios, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise based HTTP client for the browser and Node.js. From 1.0.0 to before 1.15.1, the FormDataPart constructor in lib/helpers/formDataToStream.js interpolates value.type directly into the Content-Type header of each multipart part without sanitizing CRLF (\r\n) sequences. An attacker who controls the .type property of a Blob/File-like object (e.g., via a user-uploaded file in a Node.js proxy service) can inject arbitrary MIME part headers into the multipart form-data body. This bypasses Node.js v18+ built-in header protections because the injection targets the multipart body structure, not HTTP request headers. This vulnerability is fixed in 1.15.1.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-42037?

2 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | From 1.0.0 | 1.15.1 |
| `axios` | npm | From 1.0.0 | 1.15.1 |

Products: Axios Axios.

## How do I fix CVE-2026-42037?

Upgrade axios to 1.15.1 or later.

## Is CVE-2026-42037 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42037 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42037 and fix it if it is affected.

What it is: CVE-2026-42037 is a medium-severity vulnerability in axios, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42037 exists.

Affected packages and fixed versions:
- axios (npm): affected from 1.0.0; fixed in 1.15.1
- axios (npm): affected from 1.0.0; fixed in 1.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42037/ (Markdown: https://insights.sbomify.com/CVE-2026-42037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42037
- OSV: https://osv.dev/vulnerability/CVE-2026-42037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42037/
Summaries are generated and may contain mistakes; the official description above is the record.
