# CVE-2026-42038: Axios: no_proxy bypass via IP alias allows SSRF

> Attackers can bypass no_proxy settings to route internal requests through a proxy, potentially exposing internal services.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 27 Apr 2026
- **Also known as:** CLEANSTART-2026-CD05163, CLEANSTART-2026-WH80314, DEBIAN-CVE-2026-42038, ECHO-ea2b-879b-b2dd, GHSA-m7pr-hjqh-92cm, MINI-2223-898r-m23v, MINI-33cg-m4qp-c7qf, MINI-437v-hrfp-rf9v, MINI-45mm-7rjv-3p9g, MINI-55gg-2qhj-wvvm, MINI-5ppr-6hmm-9352, MINI-5vfh-fh72-j4xj, MINI-8h84-h6f2-5c78, MINI-gp4g-j72q-vhx9, MINI-hvwx-68px-75qp, MINI-jwhm-4j6p-xqwj, MINI-m65v-29qc-rrw4, MINI-r5w9-5hgg-577h, MINI-rgq5-f8xq-278m, MINI-v342-cf4g-vrff, MINI-wfww-rq7j-gx37, MINI-wqx9-8jjm-q94v, MINI-ww7g-28ch-3hqg, MINI-x58x-9ggm-2v33, ROOT-APP-NPM-CVE-2026-42038, UBUNTU-CVE-2026-42038

## What is CVE-2026-42038?

CVE-2026-42038 is a medium-severity server-side request forgery vulnerability in axios, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise based HTTP client for the browser and Node.js. Prior to 1.15.1 and 0.31.1, he fix for no_proxy hostname normalization bypass is incomplete. When no_proxy=localhost is set, requests to 127.0.0.1 and [::1] still route through the proxy instead of bypassing it. The shouldBypassProxy() function does pure string matching — it does not resolve IP aliases or loopback equivalents. This vulnerability is fixed in 1.15.1 and 0.31.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-42038?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.31.1 |
| `axios` | npm | All versions | 0.31.1 |
| `axios` | npm | From 1.0.0 | 1.15.1 |
| `axios` | npm | From 1.0.0 | 1.15.1 |

Products: Axios Axios.

## How do I fix CVE-2026-42038?

Upgrade axios to a fixed version for your release line: 0.31.1 or 1.15.1.

## Is CVE-2026-42038 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42038 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42038 and fix it if it is affected.

What it is: CVE-2026-42038 is a medium-severity server-side request forgery vulnerability in axios, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42038 exists.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.31.1
- axios (npm): affected all versions; fixed in 0.31.1
- axios (npm): affected from 1.0.0; fixed in 1.15.1
- axios (npm): affected from 1.0.0; fixed in 1.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42038/ (Markdown: https://insights.sbomify.com/CVE-2026-42038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42038
- OSV: https://osv.dev/vulnerability/CVE-2026-42038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42038/
Summaries are generated and may contain mistakes; the official description above is the record.
