# CVE-2026-42040: Axios: Null Byte Injection via Reverse-Encoding in AxiosURLSearchParams

> Axios library incorrectly decodes null bytes in URL parameters, potentially allowing null byte injection in specific non-standard usage scenarios.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 27 Apr 2026
- **Also known as:** CLEANSTART-2026-CE61483, CLEANSTART-2026-LV58497, DEBIAN-CVE-2026-42040, ECHO-765e-d879-a5bc, GHSA-xhjh-pmcv-23jw, MINI-2344-jr23-jcqx, MINI-2428-mrc6-pfw6, MINI-2v9c-8vrh-j4cx, MINI-2vhc-hfxp-vr2w, MINI-46r5-j592-7p7h, MINI-5fcv-q6m7-44gf, MINI-6p2c-w357-w8xm, MINI-9gp5-r3h3-qpv2, MINI-9j89-gwgq-94gm, MINI-c7hq-4mcf-qwvx, MINI-f23w-5324-c7wp, MINI-g8v2-m95g-hjc9, MINI-hg8q-536r-wj4x, MINI-mmjp-7g73-62vg, MINI-mxm3-jwq9-2vjq, MINI-r243-5432-v46q, MINI-vv44-qhhm-6g32, MINI-w3g2-4539-f537, MINI-wh2f-h8vr-c5vg, ROOT-APP-NPM-CVE-2026-42040, UBUNTU-CVE-2026-42040

## What is CVE-2026-42040?

CVE-2026-42040 is a low-severity vulnerability in axios, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise based HTTP client for the browser and Node.js. Prior to 1.15.1 and 0.31.1, the encode() function in lib/helpers/AxiosURLSearchParams.js contains a character mapping (charMap) at line 21 that reverses the safe percent-encoding of null bytes. After encodeURIComponent('\x00') correctly produces the safe sequence %00, the charMap entry '%00': '\x00' converts it back to a raw null byte. Primary impact is limited because the standard axios request flow is not affected. This vulnerability is fixed in 1.15.1 and 0.31.1.

Weakness: CWE-626 (Null Byte Interaction Error (Poison Null Byte)), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-42040?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.31.1 |
| `axios` | npm | All versions | 0.31.1 |
| `axios` | npm | From 1.0.0 | 1.15.1 |
| `axios` | npm | From 1.0.0 | 1.15.1 |

Products: Axios Axios.

## How do I fix CVE-2026-42040?

Upgrade axios to a fixed version for your release line: 0.31.1 or 1.15.1.

## Is CVE-2026-42040 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42040 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42040 and fix it if it is affected.

What it is: CVE-2026-42040 is a low-severity vulnerability in axios, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42040 exists.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.31.1
- axios (npm): affected all versions; fixed in 0.31.1
- axios (npm): affected from 1.0.0; fixed in 1.15.1
- axios (npm): affected from 1.0.0; fixed in 1.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42040/ (Markdown: https://insights.sbomify.com/CVE-2026-42040/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42040
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42040
- OSV: https://osv.dev/vulnerability/CVE-2026-42040

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42040/
Summaries are generated and may contain mistakes; the official description above is the record.
