# CVE-2026-42043: Axios: Incomplete Fix for CVE-2025-62718 — NO_PROXY Protection Bypassed via RFC 1122 Loopback Subnet (127.0.0.0/8) in Axios 1.15.0


- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 10 Sep 2026
- **Also known as:** CLEANSTART-2026-RL17852, CLEANSTART-2026-VV02167, CLEANSTART-2026-WS59650, DEBIAN-CVE-2026-42043, ECHO-fce3-8e6c-9959, GHSA-pmwg-cvhr-8vh7, MINI-2mvq-252g-h98v, MINI-33gm-p6ff-93cj, MINI-3p9v-2xc2-3c76, MINI-4mf9-j5w5-j75g, MINI-77cf-w36x-99g5, MINI-88f4-f4cj-4hxx, MINI-h3w7-8262-9cfc, MINI-j82r-2w5p-wq92, MINI-mgrm-pvhw-whrf, MINI-mmmx-5qvh-mcg5, MINI-mr9r-3v78-4jxf, MINI-mwfp-jrmf-mj58, MINI-rv92-3752-xg6c, MINI-v4rh-44pw-fwfc, MINI-w24f-5xr9-59rc, MINI-w8qm-7f4m-ff74, MINI-wxh3-jcg9-jqc9, MINI-x279-wpvg-mm39, MINI-x5gh-frqv-6363, ROOT-APP-NPM-CVE-2026-42043, UBUNTU-CVE-2026-42043

## What is CVE-2026-42043?

CVE-2026-42043 is a high-severity vulnerability in axios, published on 24 Apr 2026. 

### Official description

Axios is a promise based HTTP client for the browser and Node.js. Prior to 1.15.1 and 0.31.1, an attacker who can influence the target URL of an Axios request can use any address in the 127.0.0.0/8 range (other than 127.0.0.1) to completely bypass the NO_PROXY protection. This vulnerability is due to an incomplete for CVE-2025-62718, This vulnerability is fixed in 1.15.1 and 0.31.1.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-441 (Unintended Proxy or Intermediary), CWE-183 (Permissive List of Allowed Inputs)

## Which versions are affected by CVE-2026-42043?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.31.1 |
| `axios` | npm | All versions | 0.31.1 |
| `axios` | npm | From 1.0.0 | 1.15.1 |
| `axios` | npm | From 1.0.0 | 1.15.1 |

Products: Axios Axios.

## How do I fix CVE-2026-42043?

Upgrade axios to a fixed version for your release line: 0.31.1 or 1.15.1.

## Is CVE-2026-42043 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42043 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42043 and fix it if it is affected.

What it is: CVE-2026-42043 is a high-severity vulnerability in axios, published on 24 Apr 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42043 exists.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.31.1
- axios (npm): affected all versions; fixed in 0.31.1
- axios (npm): affected from 1.0.0; fixed in 1.15.1
- axios (npm): affected from 1.0.0; fixed in 1.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42043/ (Markdown: https://insights.sbomify.com/CVE-2026-42043/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42043
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42043
- OSV: https://osv.dev/vulnerability/CVE-2026-42043

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42043/
Summaries are generated and may contain mistakes; the official description above is the record.
