CVE-2026-42047 Inngest TypeScript SDK exposes environment variables via serve() handler on unhandled HTTP methods

High 8.6 Published Updated

Unauthenticated attackers can exfiltrate environment variables and secrets from the host process by sending unsupported HTTP methods to the serve() handler.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-42047?

CVE-2026-42047 is a high-severity vulnerability in inngest-js, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Inngest is a platform for running event-driven and scheduled background functions with queueing, retries, and step orchestration. Versions 3.22.0 through 3.53.1 contain a vulnerability that allows unauthenticated remote attackers to exfiltrate environment variables from the host process via the serve() HTTP handler. The serve() handler implements GET, POST, and PUT methods. Requests using PATCH, OPTIONS, or DELETE fall through to a generic handler that returns diagnostic information. A change introduced in v3.22.0 caused this diagnostic response to include the contents of process.env, exposing any secrets, API keys, or credentials present in the environment. An application is vulnerable if its serve() endpoint is reachable via PATCH, OPTIONS, or DELETE requests, which is common in setups like Next.js Pages Router or Express's app.use(...). Not affected are Next.js App Router handlers that export only GET, POST, and PUT, and applications using the connect worker method. This issue has been fixed in version 3.54.0. To work around this issue if upgrading is not immediately possible, restrict the serve() endpoint at the framework or reverse-proxy layer to accept only GET, POST, and PUT. The Inngest serve() endpoint does not require any other HTTP methods.

Weakness: CWE-497, CWE-200

Which versions are affected by CVE-2026-42047?

2 open source packages ship an affected version, including inngest. It affects 1 product.

PackageAffectedFixed in
inngest npmFrom 3.22.03.54.0
inngest npmFrom 3.22.03.54.0

Products include Inngest Inngest.

How do I fix CVE-2026-42047?

Upgrade inngest to 3.54.0 or later.

Is CVE-2026-42047 being exploited?

There is no known exploitation of CVE-2026-42047 in the wild and no public exploit code.

Sources

Also known as GHSA-2jf5-6wwv-vhxx.

Is CVE-2026-42047 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free