{"answers":{"affected":"2 open source packages ship an affected version, including inngest. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-42047 in the wild and no public exploit code.","fix":"Upgrade inngest to 3.54.0 or later.","what":"CVE-2026-42047 is a high-severity vulnerability in inngest-js, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42047 and fix it if it is affected.\n\nWhat it is: CVE-2026-42047 is a high-severity vulnerability in inngest-js, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42047 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- inngest (npm): affected from 3.22.0; fixed in 3.54.0\n- inngest (npm): affected from 3.22.0; fixed in 3.54.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42047/ (Markdown: https://insights.sbomify.com/CVE-2026-42047/index.md)","id":"CVE-2026-42047","markdown":"https://insights.sbomify.com/CVE-2026-42047/index.md","name":"CVE-2026-42047","record":{"aliases":["GHSA-2jf5-6wwv-vhxx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Inngest TypeScript SDK","requires_auth":"none","summary":"Unauthenticated attackers can exfiltrate environment variables and secrets from the host process by sending unsupported HTTP methods to the serve() handler.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"inngest","vendor":"inngest"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-497","name":"Exposure of Sensitive System Information to an Unauthorized Control Sphere"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Inngest is a platform for running event-driven and scheduled background functions with queueing, retries, and step orchestration. Versions 3.22.0 through 3.53.1 contain a vulnerability that allows unauthenticated remote attackers to exfiltrate environment variables from the host process via the serve() HTTP handler. The serve() handler implements GET, POST, and PUT methods. Requests using PATCH, OPTIONS, or DELETE fall through to a generic handler that returns diagnostic information. A change introduced in v3.22.0 caused this diagnostic response to include the contents of process.env, exposing any secrets, API keys, or credentials present in the environment. An application is vulnerable if its serve() endpoint is reachable via PATCH, OPTIONS, or DELETE requests, which is common in setups like Next.js Pages Router or Express's app.use(...). Not affected are Next.js App Router handlers that export only GET, POST, and PUT, and applications using the connect worker method. This issue has been fixed in version 3.54.0. To work around this issue if upgrading is not immediately possible, restrict the serve() endpoint at the framework or reverse-proxy layer to accept only GET, POST, and PUT. The Inngest serve() endpoint does not require any other HTTP methods.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Inngest TypeScript SDK exposes environment variables via serve() handler on unhandled HTTP methods","id":"CVE-2026-42047","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Langflow: Path Traversal in Langflow Knowledge Bases API","id":"CVE-2026-42048"},"packages":[{"ecosystem":"npm","fixed":["3.54.0"],"introduced":["3.22.0"],"last_affected":[],"package":"inngest","purl":null,"source":"GHSA-2jf5-6wwv-vhxx"},{"ecosystem":"npm","fixed":["3.54.0"],"introduced":["3.22.0"],"last_affected":[],"package":"inngest","purl":"pkg:npm/inngest","source":"GHSA-2jf5-6wwv-vhxx"}],"prev":{"headline":"libcaca: Heap OOB write in canvas import functions caused by int overflow","id":"CVE-2026-42046"},"products":["inngest-js"],"published":"2026-05-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-08","vendors":["inngest"]},"summary":"Unauthenticated attackers can exfiltrate environment variables and secrets from the host process by sending unsupported HTTP methods to the serve() handler.","url":"https://insights.sbomify.com/CVE-2026-42047/"}