# CVE-2026-42048: Langflow: Path Traversal in Langflow Knowledge Bases API

> An authenticated attacker can delete arbitrary directories on the server via path traversal in the Knowledge Bases API, causing data loss and service disruption.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 13 May 2026
- **Also known as:** GHSA-9whx-c884-c68q, PYSEC-2026-377

## What is CVE-2026-42048?

CVE-2026-42048 is a critical path traversal vulnerability in Langflow Langflow, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to 1.9.0, Langflow is vulnerable to Path Traversal in the Knowledge Bases API (DELETE /api/v1/knowledge_bases). This occurs because user-supplied knowledge base names are concatenated directly into file paths without proper sanitization or boundary validation. An authenticated attacker can exploit this flaw to delete arbitrary directories anywhere on the server's filesystem, leading to data loss and potential service disruption. This vulnerability is fixed in 1.9.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-42048?

3 open source packages ship an affected version, including langflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | All versions | 1.9.0 |
| `langflow` | PyPI | All versions | 1.9.0 |
| `langflow` | PyPI | All versions | 1.9.0 |

Products: Langflow Langflow.

## How do I fix CVE-2026-42048?

Upgrade langflow to 1.9.0 or later.

## Is CVE-2026-42048 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42048 exists.

Public exploit code:

- Langflow Arbitrary Directory Deletion (github_poc): https://github.com/EQSTLab/CVE-2026-42048

## Other vulnerabilities in Langflow Langflow

- [CVE-2026-9198](https://insights.sbomify.com/CVE-2026-9198/): IBM Langflow Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-0770](https://insights.sbomify.com/CVE-2026-0770/): Langflow Inclusion of Functionality from Untrusted Control Sphere (critical 9.8, exploited in the wild)
- [CVE-2025-3248](https://insights.sbomify.com/CVE-2025-3248/): Langflow Missing Authentication (critical 9.8, exploited in the wild)
- [CVE-2025-34291](https://insights.sbomify.com/CVE-2025-34291/): Langflow Origin Validation Error (critical 9.4, exploited in the wild)
- [CVE-2026-33017](https://insights.sbomify.com/CVE-2026-33017/): Langflow Code Injection (critical 9.3, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42048 and fix it if it is affected.

What it is: CVE-2026-42048 is a critical path traversal vulnerability in Langflow Langflow, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42048 exists.

Affected packages and fixed versions:
- langflow (PyPI): affected all versions; fixed in 1.9.0
- langflow (PyPI): affected all versions; fixed in 1.9.0
- langflow (PyPI): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42048/ (Markdown: https://insights.sbomify.com/CVE-2026-42048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42048
- OSV: https://osv.dev/vulnerability/CVE-2026-42048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42048/
Summaries are generated and may contain mistakes; the official description above is the record.
